SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 Service Broker (2005)
 Service Broker pointing to wrong DB
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

SuperJB
Starting Member

12 Posts

Posted - 04/19/2012 :  06:59:39  Show Profile  Reply with Quote
Hello everyone,

Situation:
- I have 2 databases (DB_A and DB_B). They have Service Broker configured between them and it's working fine.
- A new environment for our application was needed but we didn't have any new "free" servers. So, the solution was to create 2 new databaes (DB_A2 and DB_B2) that were restored from the original DBs on the same instance.
- Now, my DB_B2 Service Broker is "speaking" with DB_A instead of DB_A2.

Can anyone tell me what I must do to configure the SB correctly?

Thanks in advance guys...


SuperJB

Edited by - SuperJB on 04/19/2012 07:00:33

nathans
Aged Yak Warrior

USA
938 Posts

Posted - 04/30/2012 :  01:27:56  Show Profile  Reply with Quote
When restoring the dbs be sure to specify NEW_BROKER. This will create new broker GUIDs for use in routing. This may be the source of your issue.

Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.08 seconds. Powered By: Snitz Forums 2000