SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 Replication (2005)
 Data Changes not Replicating to Subscribers
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

IainRobertson
Starting Member

1 Posts

Posted - 10/04/2012 :  09:44:10  Show Profile  Reply with Quote
Hi,

I have an application that makes changes to a replicated database. It does this via various stored procedures that are already in production and that are known to be working properly.

The application makes changes, but these changes are not being replicated to subscibers for the majority of records, although the occasional one does get propogated.

The changes are generating records in MSMerge_contents. The MSmerge_contents record has a generation number that is higher than the sentgen value for the subscriber in sysmergesubscriptions. But for some reason, the change just isn't picked up. Manually changing the record via Management Studio resolves the problem and the change propogates.

I'm at a loss to understand quite why this is happening. Any advice would be welcomed.

Publisher: Microsoft SQL Server 2005 - 9.00.4262.00 (X64) Standard Edition (64-bit) on Windows NT 5.2 (Build 3790: Service Pack 2)

Subscribers: Microsoft SQL Server 2005 - 9.00.3080.00 (Intel X86) Workgroup Edition on Windows NT 5.1 (Build 2600: Service Pack 2)

or

Microsoft SQL Server 2005 - 9.00.4053.00 (Intel X86) Express Edition with Advanced Services on Windows NT 5.1 (Build 2600: Service Pack 2)

sodeep
Flowing Fount of Yak Knowledge

USA
7174 Posts

Posted - 11/16/2012 :  22:39:52  Show Profile  Reply with Quote
What changes are you refering to? Data Changes or Schema Changes?
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.08 seconds. Powered By: Snitz Forums 2000