Please start any new threads on our new site at http://forums.sqlteam.com. We've got lots of great SQL Server experts to answer whatever question you can come up with.

Our new SQL Server Forums are live! Come on over! We've restricted the ability to create new threads on these forums.

SQL Server Forums
Profile | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2008 Forums
 SSIS and Import/Export (2008)
 SSIS package not working with different profile
 Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

ShorePatrol
Starting Member

4 Posts

Posted - 12/17/2012 :  14:46:31  Show Profile  Reply with Quote
Folks,

We had a pretty bad situation - everytime I would log onto the SQL 2008 server (I'm a domain admin) I'd be OK for a few minutes, and then it would blue screen. This started happening out of the blue (pun intended), with no Windows updates or changes...this also happens if I RDP to it with this profile.

We quickly realized other profiles/users were fine...so I could log on with a domain service account I use for other things, and it would not crash.

So the plan became to remove the old profile, recreate it, and hope for the best...

HERE'S THE PROBLEM: I've copied the SSIS packages from the old profile location to the new profile. SSIS will open the project file, but when I try to open the package, I get errors "Failed to decrypt protected XML node DTS:Password Key not valid for use in specified state"

Is there a way (if so how) I can open these packages while logged on as a different user than who created them???

At this point I still have the old profile, but afraid to use it since it crashes the server.

Any advice REALLY appreciated!

Thanks!

nelsont
Starting Member

USA
25 Posts

Posted - 12/28/2012 :  11:15:44  Show Profile  Reply with Quote
Before you open the project,
Go to Tools --> Options --> Business Intelligence Designers --> Integration Service Designers
Uncheck the "Check digital signature" box.

Hope this fixes it.
Go to Top of Page

ShorePatrol
Starting Member

4 Posts

Posted - 01/02/2013 :  10:07:07  Show Profile  Reply with Quote
quote:
Originally posted by nelsont

Before you open the project,
Go to Tools --> Options --> Business Intelligence Designers --> Integration Service Designers
Uncheck the "Check digital signature" box.

Hope this fixes it.



Thanks! I tried it, but this is the error I get:
Error loading Package.dtsx: Failed to decrypt protected XML node "DTS:Password" with error 0x8009000B "Key not valid for use in specified state.". You may not be authorized to access this information. This error occurs when there is a cryptographic error. Verify that the correct key is available.

I'm assuming this is due to the passwords in the connection manager...?

Not sure how to fix this since I can no longer use the login that was used to create the packages....

Is it as simple as re-creating the connections for the package? I guess that's my next thing to try....
Go to Top of Page
  Previous Topic Topic Next Topic  
 Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.05 seconds. Powered By: Snitz Forums 2000