SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 General SQL Server Forums
 New to SQL Server Administration
 cannot enable 'sa' login
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

sumith
Starting Member

India
1 Posts

Posted - 02/14/2013 :  14:37:00  Show Profile  Reply with Quote
there are 5 logins includes login 'sa' in sql server.
'sa' login is not enabled.

All users except 'sa' are not 'sysadmin'.

the other users have 'public' role only. (they cannot create any database or change privileges of user).

i tried to enable 'sa' login . but it failed due to insuuficient rights of login

what i do to enable 'sa' account'

srimami
Posting Yak Master

160 Posts

Posted - 02/14/2013 :  18:29:50  Show Profile  Reply with Quote
Right click on sever (Object Explorer), go to security and change the settings as required.
Go to Top of Page

jeffw8713
Aged Yak Warrior

USA
788 Posts

Posted - 02/15/2013 :  14:04:27  Show Profile  Reply with Quote
First, verify that SQL Server has been configured for both Windows and SQL Authentication. If it is only Windows authentication - enabling/disabling the sa account will have no effect.

Second, if SQL authentication is available - verify that you are logged in with a sysadmin level account. If - as you say above - the only login available with sysadmin rights is sa, then you will need to use the following process: http://blogs.msdn.com/b/raulga/archive/2007/07/12/disaster-recovery-what-to-do-when-the-sa-account-password-is-lost-in-sql-server-2005.aspx

And finally, if you only have windows authentication available - then you need to follow the same type of procedure but instead of making the change to the sa account you would add your own account and set it as sysadmin.

All options will require an outage...
Go to Top of Page

Jeff Moden
Aged Yak Warrior

USA
649 Posts

Posted - 02/15/2013 :  20:41:23  Show Profile  Reply with Quote
quote:
Originally posted by srimami

Right click on sever (Object Explorer), go to security and change the settings as required.



Read the orginal post. How is the OP going to do as you suggest when none of the logins (including the OPs) have the privs to change security.

--Jeff Moden
RBAR is pronounced "ree-bar" and is a "Modenism" for "Row By Agonizing Row".

First step towards the paradigm shift of writing Set Based code:
"Stop thinking about what you want to do to a row... think, instead, of what you want to do to a column."

When writing schedules, keep the following in mind:
"If you want it real bad, that's the way you'll likely get it."
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.06 seconds. Powered By: Snitz Forums 2000