SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 General SQL Server Forums
 New to SQL Server Administration
 never made 'sa' password in sql 2000
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

mcgruff
Starting Member

Canada
4 Posts

Posted - 12/02/2013 :  23:33:01  Show Profile  Reply with Quote
i installed sql server 2000 because another program (MV Engineering assistant powered by AMS 6.1 )needs it to run, now during the install i receive a msg saying "SQL server exists on this PC enter the SQL server password for the 'sa' administrator account" but i was not prompted to make any sa password and do not know what it is. it is stopping me from installing a application i need for work and i need this solved, i have to use sql server 2000 and it needs sql 2000 service pack 3 specifically and i am running windows xp service pack 1

when the password is left blank it says
the SQL server password entered for the "sa" administrator account is incorrect.
Check to make sure that the SQL server is set up for mixed mode authentication.

this is what the Manuel for program i am installing says regarding the sa password, i simply dont know enugh about sql to figure it out.

• If SQL Server 2000 SP3 is already installed, the AMS installation program will
continue with the next part of the installation program. (Access to the SQL
Server ‘sa’ account is required. If you don’t have access, contact your network
administrator for more information.)

A Microsoft SQL Server 'sa' account password is not required for AMS operation.
Therefore, the AMS 6.1 setup does not create an 'sa' password. However, for
security reasons, it is recommended that you configure your SQL Server to
require a password. After installing AMS, determine if your SQL Server should be
password-protected (if you are unsure, ask your network administrator). If you find
that your SQL Server application is password-protected, no further steps are
necessary.

Edited by - mcgruff on 12/03/2013 01:50:16

mcgruff
Starting Member

Canada
4 Posts

Posted - 12/02/2013 :  23:40:02  Show Profile  Reply with Quote
also i am extremly new to sql and the forum, I want to Hello to all and i apoligise that i am a noob and my first post is question. I am looking forward to learning about sql with you all
Go to Top of Page

mcgruff
Starting Member

Canada
4 Posts

Posted - 12/03/2013 :  00:05:35  Show Profile  Reply with Quote
also i dont seem to have Management Studio installed and cant seem to find it for 2000
Go to Top of Page

visakh16
Very Important crosS Applying yaK Herder

India
52317 Posts

Posted - 12/03/2013 :  06:41:44  Show Profile  Reply with Quote
quote:
Originally posted by mcgruff

also i dont seem to have Management Studio installed and cant seem to find it for 2000


SQL 2000 installation doeant come with management studio. Its client tools include query analyser for running queries and Enterprise Manager for registering server instances and do activities through GUI

------------------------------------------------------------------------------------------------------
SQL Server MVP
http://visakhm.blogspot.com/
https://www.facebook.com/VmBlogs
Go to Top of Page

jeffw8713
Aged Yak Warrior

USA
798 Posts

Posted - 12/03/2013 :  13:23:09  Show Profile  Reply with Quote
It sounds like the SQL Server install was not done with mixed mode - so you only have Windows Authentication enabled. To fix that, you will need to locate Enterprise Manager and see if you can access the instance. If you can do that, then switch the authentication method on the Server Properties, set the sa account password and restart SQL Server.

You should then be able to continue with your installation.
Go to Top of Page

mcgruff
Starting Member

Canada
4 Posts

Posted - 12/03/2013 :  21:05:36  Show Profile  Reply with Quote
thank you, i cant seem to find enterprise manager on the computer and it did not appear to install with sql2000 desktop edition when i installed it. I tried to install the one from 2008 but it did not work

quote:
Originally posted by jeffw8713

It sounds like the SQL Server install was not done with mixed mode - so you only have Windows Authentication enabled. To fix that, you will need to locate Enterprise Manager and see if you can access the instance. If you can do that, then switch the authentication method on the Server Properties, set the sa account password and restart SQL Server.

You should then be able to continue with your installation.

Go to Top of Page

jeffw8713
Aged Yak Warrior

USA
798 Posts

Posted - 12/04/2013 :  14:56:11  Show Profile  Reply with Quote
If I recall correctly - the desktop edition does not come with Enterprise Manager. You would have to download that separately - if you can even find it.

If you download the SQL Server 2005 Management Studio Express you should be able to use that.

Now, with all of that said - I would recommend that you try SQL Server 2005 Express instead of 2000. When you build out the system, you can set the compatibility level of the database to 80 (2000) and it should work. No guarantees, of course...
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
37134 Posts

Posted - 12/04/2013 :  15:21:52  Show Profile  Visit tkizer's Homepage  Reply with Quote
quote:
Originally posted by jeffw8713

If I recall correctly - the desktop edition does not come with Enterprise Manager. You would have to download that separately - if you can even find it.




MSDE didn't even have a downloadable GUI, from Microsoft at least. There are probably open source/free solutions out there.

I once had to work on an MSDE server and could not get a GUI to connect to it. I was stuck writing commands in osql.exe. I am a command-type person, but geez there's so much you have to lookup.

Tara Kizer
SQL Server MVP since 2007
http://weblogs.sqlteam.com/tarad/
Go to Top of Page

Bustaz Kool
Flowing Fount of Yak Knowledge

USA
1754 Posts

Posted - 12/05/2013 :  19:09:39  Show Profile  Reply with Quote
If the issue is that you need to enter Mixed Mode, here is a link on how to manually configure this via the registry:
http://support.microsoft.com/kb/322336

HTH

=================================================
No, no, you're not thinking, you're just being logical. -Niels Bohr
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.08 seconds. Powered By: Snitz Forums 2000