SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2008 Forums
 Analysis Server and Reporting Services (2008)
 Getting Errors when deploying the SSAS solution
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

learntsql
Aged Yak Warrior

India
507 Posts

Posted - 12/04/2013 :  05:58:31  Show Profile  Reply with Quote
Hi All,

When I try to deploy the SSAS.sln, I get the following errors:

Error 24 OLE DB error: OLE DB or ODBC error: Invalid object name 'dbo.SSAS_XYZ'.; 42S02. 0 0
Error 25 Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Customer Region', Name of 'CUSTOMER' was being processed. 0 0
Error 26 Errors in the OLAP storage engine: An error occurred while the 'Midea GROUP' attribute of the 'CUSTOMER' dimension from the 'SSAS' database was being processed. 0 0
Error 27 Server: The current operation was cancelled because another operation in the transaction failed. 0 0
like this i am getting for all dimension in my solution.
Please guide me what is causing the issue.
How to rectify it.
TIA.

visakh16
Very Important crosS Applying yaK Herder

India
52249 Posts

Posted - 12/04/2013 :  06:17:52  Show Profile  Reply with Quote
check if your source has table 'dbo.SSAS_XYZ'

------------------------------------------------------------------------------------------------------
SQL Server MVP
http://visakhm.blogspot.com/
https://www.facebook.com/VmBlogs
Go to Top of Page

learntsql
Aged Yak Warrior

India
507 Posts

Posted - 12/04/2013 :  06:37:59  Show Profile  Reply with Quote
Hi Visakh,

Thanks for your Quick reply.
I checked in my DSV and Relational DB, i dont have that object exists.
Even i am unable to find it in my SSAS solution.
Can you please tell me how can we troubleshoot it.
TIA.
Go to Top of Page

learntsql
Aged Yak Warrior

India
507 Posts

Posted - 12/04/2013 :  07:33:26  Show Profile  Reply with Quote
Sorry Visakh,

I checked again and this object is being used in one of the named queires Named Query that i am currently not found the DB.Let me check on that.
But why i am getting the remaining errors like
Error 25 Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Customer Region', Name of 'CUSTOMER' was being processed. 0 0
Error 26 Errors in the OLAP storage engine: An error occurred while the 'Midea GROUP' attribute of the 'CUSTOMER' dimension from the 'SSAS' database was being processed. 0 0
Error 27 Server: The current operation was cancelled because another operation in the transaction failed. 0 0
Can you please help me on this.
TIA.
Go to Top of Page

visakh16
Very Important crosS Applying yaK Herder

India
52249 Posts

Posted - 12/04/2013 :  08:07:15  Show Profile  Reply with Quote
quote:
Originally posted by learntsql

Sorry Visakh,

I checked again and this object is being used in one of the named queires Named Query that i am currently not found the DB.Let me check on that.
But why i am getting the remaining errors like
Error 25 Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Customer Region', Name of 'CUSTOMER' was being processed. 0 0
Error 26 Errors in the OLAP storage engine: An error occurred while the 'Midea GROUP' attribute of the 'CUSTOMER' dimension from the 'SSAS' database was being processed. 0 0
Error 27 Server: The current operation was cancelled because another operation in the transaction failed. 0 0
Can you please help me on this.
TIA.


ok check the datasource information, go to the database and see if that object exists first and you've access to it using the account you use to deploy the cube.
that should be the first step.

------------------------------------------------------------------------------------------------------
SQL Server MVP
http://visakhm.blogspot.com/
https://www.facebook.com/VmBlogs
Go to Top of Page

learntsql
Aged Yak Warrior

India
507 Posts

Posted - 12/04/2013 :  08:44:50  Show Profile  Reply with Quote
Hi Visakh,

I sloved those issues and now i am getting a new one saying

Error 27 Errors in the OLAP storage engine: An error occurred
while processing the 'Sales' partition of the 'MEASURES' measure group for the 'SSAS' cube from the SSAS database.

It is also showing some message when i mouse over on 'MEASURES' saying..
"Slpit Large partitions,with more than 20 million rows or that are over 250 MBin size into smaller partitions to improve the performanace"

Is this causing to fail the deployment.other than this it is not showing any other message.
TIA.
Go to Top of Page

visakh16
Very Important crosS Applying yaK Herder

India
52249 Posts

Posted - 12/04/2013 :  09:43:15  Show Profile  Reply with Quote
quote:
Originally posted by learntsql

Hi Visakh,

I sloved those issues and now i am getting a new one saying

Error 27 Errors in the OLAP storage engine: An error occurred
while processing the 'Sales' partition of the 'MEASURES' measure group for the 'SSAS' cube from the SSAS database.

It is also showing some message when i mouse over on 'MEASURES' saying..
"Slpit Large partitions,with more than 20 million rows or that are over 250 MBin size into smaller partitions to improve the performanace"

Is this causing to fail the deployment.other than this it is not showing any other message.
TIA.



it seems like you've overlapping partitions. Can you check the source queries for partitions in the cube (you can go to partition tab for that). Make sureno two partitions include overlapping set of data for a given measure group ie check the WHERE conditions

------------------------------------------------------------------------------------------------------
SQL Server MVP
http://visakhm.blogspot.com/
https://www.facebook.com/VmBlogs
Go to Top of Page

learntsql
Aged Yak Warrior

India
507 Posts

Posted - 12/05/2013 :  04:07:57  Show Profile  Reply with Quote
Thanks Visakh,

I checked Partitions tab and there are 7 partitions created and out of them only 1 partition has WHERE clause that to it is using YEAR comparision, rest all partitions are using VIEWS in its FROM clause.

Can you please guide me, what is causing issue.
TIA.
Go to Top of Page

learntsql
Aged Yak Warrior

India
507 Posts

Posted - 12/05/2013 :  06:14:39  Show Profile  Reply with Quote
Can some one please guide on this issue.
your help is really appreciated..
TIA.
Go to Top of Page

visakh16
Very Important crosS Applying yaK Herder

India
52249 Posts

Posted - 12/05/2013 :  13:22:26  Show Profile  Reply with Quote
quote:
Originally posted by learntsql

Thanks Visakh,

I checked Partitions tab and there are 7 partitions created and out of them only 1 partition has WHERE clause that to it is using YEAR comparision, rest all partitions are using VIEWS in its FROM clause.

Can you please guide me, what is causing issue.
TIA.



check the where conditions within the view and make sure they dont overlap.

------------------------------------------------------------------------------------------------------
SQL Server MVP
http://visakhm.blogspot.com/
https://www.facebook.com/VmBlogs
Go to Top of Page

learntsql
Aged Yak Warrior

India
507 Posts

Posted - 12/10/2013 :  10:34:36  Show Profile  Reply with Quote
Hi Visakh,

Thank you for your reply.
I have one more query here.
In my dimension table for one of the columns i am getting Blank value in cube.
How can i suppress this in the cube?
Please guide me.
TIA.
Go to Top of Page

learntsql
Aged Yak Warrior

India
507 Posts

Posted - 12/11/2013 :  02:54:16  Show Profile  Reply with Quote
Hi All,

Could you please tell me how can i suppress/eliminate the blank value in the dimension for one of the columns.
Please suggest me.
TIA.
Go to Top of Page

visakh16
Very Important crosS Applying yaK Herder

India
52249 Posts

Posted - 12/11/2013 :  12:25:08  Show Profile  Reply with Quote
quote:
Originally posted by learntsql

Hi All,

Could you please tell me how can i suppress/eliminate the blank value in the dimension for one of the columns.
Please suggest me.
TIA.


blank value as dimension member value you mean? or blank value for measure in cube browser? If latter click Hide empty cells option in cube browser

------------------------------------------------------------------------------------------------------
SQL Server MVP
http://visakhm.blogspot.com/
https://www.facebook.com/VmBlogs
Go to Top of Page

learntsql
Aged Yak Warrior

India
507 Posts

Posted - 12/12/2013 :  03:49:05  Show Profile  Reply with Quote
Thank you Visakh for the quick reply.
I am getting blank value as dimension member value.
Go to Top of Page

visakh16
Very Important crosS Applying yaK Herder

India
52249 Posts

Posted - 12/12/2013 :  12:05:01  Show Profile  Reply with Quote
then thats problem with named query or table data. check if dimension has a record with blank value for related field in database.

------------------------------------------------------------------------------------------------------
SQL Server MVP
http://visakhm.blogspot.com/
https://www.facebook.com/VmBlogs
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.11 seconds. Powered By: Snitz Forums 2000