SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2000 Forums
 SQL Server Administration (2000)
 databases ? I see no databases...
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Simon_L
Starting Member

United Kingdom
32 Posts

Posted - 05/14/2008 :  06:34:55  Show Profile  Reply with Quote
Using a box Ive got , sql 2000, mixed mode security , allow remote connections etc unless I grant a windows user sa rights it can connect to the server but cant see any databases

If you give it public and datareader/writer to a db it still cant see it

Im embarressed to ask as its bound to be simple but there you go !

~si

RickD
Slow But Sure Yak Herding Master

United Kingdom
3603 Posts

Posted - 05/14/2008 :  07:02:04  Show Profile  Reply with Quote
What tool are the users connecting with? What service pack level is the SQL Server?

Edited by - RickD on 05/14/2008 07:02:28
Go to Top of Page

Simon_L
Starting Member

United Kingdom
32 Posts

Posted - 05/14/2008 :  07:10:55  Show Profile  Reply with Quote
SQL Server 2000 SP3 and trying to connect via EM
Go to Top of Page

RickD
Slow But Sure Yak Herding Master

United Kingdom
3603 Posts

Posted - 05/14/2008 :  09:51:01  Show Profile  Reply with Quote
You might want to upgrade that to SP4 for a start, SP3 is no longer supported.
Go to Top of Page

Simon_L
Starting Member

United Kingdom
32 Posts

Posted - 05/14/2008 :  09:55:50  Show Profile  Reply with Quote
I dont think thats related to the problem as both server and my local EM are at SP3 but its worth doing anyways

thanks simon
Go to Top of Page

mcrowley
Aged Yak Warrior

771 Posts

Posted - 05/14/2008 :  10:17:42  Show Profile  Reply with Quote
Do you mean user databases, or the databases that SQL Server ships with (master, msdb, tempdb)? There is a setting in EM somewhere to hide system objects. Can the database(s) be used by the user within Query Analyzer?
Go to Top of Page

Simon_L
Starting Member

United Kingdom
32 Posts

Posted - 05/14/2008 :  10:25:41  Show Profile  Reply with Quote
User databases, EM says no objects found under the databases tab, interestingly I can see the database and tables in query analyser in the tree view and by querying them
Go to Top of Page

mcrowley
Aged Yak Warrior

771 Posts

Posted - 05/14/2008 :  10:31:56  Show Profile  Reply with Quote
Since you can see them in Query Analyzer, that leads me to believe the problem is in EM itself. Problems with EM are pretty hard to troubleshoot, and generally end up with "remove and reinstall" as the solution. Is this the only workstation having this problem?
Go to Top of Page

Simon_L
Starting Member

United Kingdom
32 Posts

Posted - 05/14/2008 :  11:34:09  Show Profile  Reply with Quote
well what is now really confuses me is whichever machine I access the server with (using different users in each case) and in each case EM fails and query analyser succedes
Go to Top of Page

rmiao
Flowing Fount of Yak Knowledge

USA
7266 Posts

Posted - 05/14/2008 :  23:35:50  Show Profile  Reply with Quote
Even on server itself? Tried reboot your pc? Tried reinstall sql tools on your pc?
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.09 seconds. Powered By: Snitz Forums 2000