Please start any new threads on our new site at We've got lots of great SQL Server experts to answer whatever question you can come up with.

Our new SQL Server Forums are live! Come on over! We've restricted the ability to create new threads on these forums.

SQL Server Forums
Profile | Active Topics | Members | Search | Forum FAQ
Register Now and get your question answered!
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 Other SQL Server Topics (2005)
 SSIS security
 Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Starting Member

1 Posts

Posted - 01/21/2009 :  16:20:09  Show Profile  Reply with Quote
I wrote several SSIS packages that performed maintenance tasks. They ran great until I needed to rebuild the server from which they were executing.The 3 tasks that are giving me trouble are execute process tasks.See below.

c:\windows\system32\sc.exe \\Distcorp2 stop "SQLSERVERAGENT"
c:\windows\system32\sc.exe \\Distcorp2 stop "MSSQLSERVER"
c:\windows\psshutdown.exe \\Distcorp2 /r /e P:1:1

Microsoft (R) SQL Server Execute Package Utility
Version 9.00.3042.00 for 32-bit
Copyright (C) Microsoft Corp 1984-2005. All rights reserved.

Started: 1:34:28 PM
Error: 2009-01-21 13:39:29.29
Code: 0xC002914C
Source: Re-Boot DistCorp2 Execute Process Task
Description: The process timed out.
End Error
DTExec: The package execution returned DTSER_FAILURE (1).
Started: 1:34:28 PM
Finished: 1:39:29 PM
Elapsed: 300.734 seconds

1. Logging into the executing server as domain admin, I can successfully execute each one of these commands from the command prompt.
2. I also can successfully execute the package from the package store.
3. I created a SQL Agent job with 3 steps, each step executing these steps in the above order. The SQLSERVERAGENT successfully stops, but the next 2 steps never execute.
4. I now believe this is security related so I gave full server access to SPWEB1\SQLServer2005SQLAgentUser$SPWEB1$MSSQLSERVER, which I believe is the agent account. Still no luck.
5. I tried using a proxy with credentials, but may not have done it correctly because it did not solve my problem.

Any help you can provide will be greatly appreciated.

Constraint Violating Yak Guru

420 Posts

Posted - 07/07/2013 :  06:02:38  Show Profile  Reply with Quote
Any solution?
Go to Top of Page

Very Important crosS Applying yaK Herder

52326 Posts

Posted - 07/08/2013 :  01:42:46  Show Profile  Reply with Quote
First check if the account Agent uses has access to physical paths \\Distcorp2 etc which is used by process.
Secondly make sure that Agent is using the same account itself.
Also you didnt specify what issue you faced when using proxy. The ideal way to do this is by setting up a proxy account giving it only the required permissions to execute.

SQL Server MVP
Go to Top of Page
  Previous Topic Topic Next Topic  
 Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.04 seconds. Powered By: Snitz Forums 2000