SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Old Forums
 CLOSED - General SQL Server
 Scheduled Job Fails
 Forum Locked
 Printer Friendly
Author Previous Topic Topic Next Topic  

TJ
Posting Yak Master

USA
201 Posts

Posted - 01/04/2002 :  13:00:51  Show Profile
I have an sproc that runs 5 sprocs (1- Link server1 to server2, 2-Log onto server2, 3-run a query that inserts recs into a table on server2, and update recs in a table on server1, 4-log off of server2, 5- drop the link to server2) that runs when you execute it in query analyzer. We're trying to set up a job to run it from server1. I'm getting the following error message:

Msg 7410, sev 16: Remote access not allowed for windows nts user activated by setuser. [sqlstate 42000]

We're pretty sure it's a permissions problem, but can't seem to find what setting(s) need changed.

Any help would be greatly appreciated.

Thanks!
Teresa

izaltsman
A custom title

USA
1139 Posts

Posted - 01/04/2002 :  13:22:33  Show Profile  Send izaltsman an AOL message  Send izaltsman an ICQ Message
Is your SQLAgent running in a domain account? (it should be -- otherwise you will not be able to access remote machines from any of your jobs)

Go to Top of Page

TJ
Posting Yak Master

USA
201 Posts

Posted - 01/04/2002 :  13:56:55  Show Profile
quote:

Is your SQLAgent running in a domain account? (it should be -- otherwise you will not be able to access remote machines from any of your jobs)



Please bear with me, I'm a novice.

Where do I look to find this out? Do I look on server1 or server2? Is there a correlation between them that I need to consider also?

Go to Top of Page

izaltsman
A custom title

USA
1139 Posts

Posted - 01/04/2002 :  14:19:14  Show Profile  Send izaltsman an AOL message  Send izaltsman an ICQ Message
Sounds like you are going to create and run this job on server1. Therefore, SQLAgent on server1 should run in a domain account. To find out:

In Enterprise Manager, go to server1\Management.
Right-click on SQL Server Agent
On the General Tab, make sure you have selected "This Account" option and entered valid account information in the appropriate textboxes.

Go to Top of Page
  Previous Topic Topic Next Topic  
 Forum Locked
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.1 seconds. Powered By: Snitz Forums 2000