SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2008 Forums
 Other SQL Server 2008 Topics
 not able to telnet sql port 1433 remotly
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

kediacommodity1
Starting Member

India
9 Posts

Posted - 03/09/2009 :  12:11:36  Show Profile  Send kediacommodity1 a Yahoo! Message  Reply with Quote
i am using windows 2003 server and sql 2000
when i telnet locally its working and when i am trying to do telnet from remotely its not work.

i am check in sql logs 1433 port in listening

vijay kedia
kediacommodity1@yahoo.co.in

guptam
Posting Yak Master

Canada
161 Posts

Posted - 03/09/2009 :  20:16:45  Show Profile  Visit guptam's Homepage  Click to see guptam's MSN Messenger address  Reply with Quote
Check to make sure that your SQL Server allows remote connections and there is no firewall between server and your remote host. Thanks.


--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/
Go to Top of Page

kediacommodity1
Starting Member

India
9 Posts

Posted - 03/12/2009 :  03:15:49  Show Profile  Send kediacommodity1 a Yahoo! Message  Reply with Quote
Dear Sir,

i am checked i am useing firewall but i exclude the sql serv and ports/
Go to Top of Page

kediacommodity1
Starting Member

India
9 Posts

Posted - 03/12/2009 :  03:19:07  Show Profile  Send kediacommodity1 a Yahoo! Message  Reply with Quote
locally i am able to do telnet and in in sql logs i am getting that port 1433 listning.
only problem is that from remote i am not able to telnet.


REgards

quote:
Originally posted by kediacommodity1

i am using windows 2003 server and sql 2000
when i telnet locally its working and when i am trying to do telnet from remotely its not work.

i am check in sql logs 1433 port in listening

vijay kedia
kediacommodity1@yahoo.co.in



Go to Top of Page

guptam
Posting Yak Master

Canada
161 Posts

Posted - 03/12/2009 :  06:39:06  Show Profile  Visit guptam's Homepage  Click to see guptam's MSN Messenger address  Reply with Quote
I need you to check that firewall allows port port 1433 through? And you can check the remote setting on sql server with following script:

sp_configure "remote access"

Can you paste the error message?

--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/
Go to Top of Page

kediacommodity1
Starting Member

India
9 Posts

Posted - 03/12/2009 :  13:52:54  Show Profile  Send kediacommodity1 a Yahoo! Message  Reply with Quote
Dear

I again checked the firewall i added the tcp and udp port 1433 in exemption list.

when i use telnet xxx.xx.xx.xx 1433 blace screen comes and disappere.

when i verify ODBC Data source i get error:

Connection Failed:
SQL Stata :01000
Sql server Error :10060
{microsoft][odbcsql server driver][tcp/ip Socket] ConnectionOpen (connect)
Connection Failed
sql stata :08001
sql server error :17
{microsoft][odbcsql server driver] (tcp/ip socket) sql server does not exist or acess dinied.

Please find some solution

Regards

vijay and mail a copy to me on kediacommodity1@yahoo.co.in














quote:
Originally posted by guptam

I need you to check that firewall allows port port 1433 through? And you can check the remote setting on sql server with following script:

sp_configure "remote access"

Can you paste the error message?

--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/

Go to Top of Page

guptam
Posting Yak Master

Canada
161 Posts

Posted - 03/12/2009 :  14:04:22  Show Profile  Visit guptam's Homepage  Click to see guptam's MSN Messenger address  Reply with Quote
Hmm are your protocol enabled?

Go to SQL Server Configuration Manager on the server

Then go to SQL Server 2005 Network Configuration

And check to make sure you have at least one of TCP/IP or Named pipes enabled.

Thanks.

--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/
Go to Top of Page

kediacommodity1
Starting Member

India
9 Posts

Posted - 03/13/2009 :  02:05:10  Show Profile  Send kediacommodity1 a Yahoo! Message  Reply with Quote

Dear Sir,

i checked tcp/ip and name pipe are enabled.

Regards
vijay


quote:
Originally posted by guptam

Hmm are your protocol enabled?

Go to SQL Server Configuration Manager on the server

Then go to SQL Server 2005 Network Configuration

And check to make sure you have at least one of TCP/IP or Named pipes enabled.

Thanks.

--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/

Go to Top of Page

guptam
Posting Yak Master

Canada
161 Posts

Posted - 03/13/2009 :  02:09:50  Show Profile  Visit guptam's Homepage  Click to see guptam's MSN Messenger address  Reply with Quote
Did you check run ...

sp_configure 'remote access'

On the server? That is the only other thing I can think of.. Firewall good, Protocols Good ... Then it must not allow remote connections on the server; check SQL Server logs and event logs on the server to see if there is anything.

Try pinging SQL Server from your other computer to see if Ping goes through...
Thanks.


--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/
Go to Top of Page

kediacommodity1
Starting Member

India
9 Posts

Posted - 03/13/2009 :  08:19:16  Show Profile  Send kediacommodity1 a Yahoo! Message  Reply with Quote
dEAR sIR,

I AM NOT ABLE TO OPEN SP_CONFIGURE "REMOTE ACCESS" CAN SEND ME THE DETAILS

HOW I CAN DO

REGARDS


quote:
Originally posted by guptam

Did you check run ...

sp_configure 'remote access'

On the server? That is the only other thing I can think of.. Firewall good, Protocols Good ... Then it must not allow remote connections on the server; check SQL Server logs and event logs on the server to see if there is anything.

Try pinging SQL Server from your other computer to see if Ping goes through...
Thanks.


--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/

Go to Top of Page

guptam
Posting Yak Master

Canada
161 Posts

Posted - 03/13/2009 :  11:44:08  Show Profile  Visit guptam's Homepage  Click to see guptam's MSN Messenger address  Reply with Quote
On the SQL Server in question ..
Launch SSMS and Connect to server.
Start a New Query
Type in "sp_configure 'remote access'"
Press F5 (run).

Alternatively...

On The SQL Server in Question
Launch SSMS and Connect to server.
Right click on server go to Properties.
Click Connections.
Select "Allow remote connections on server".
Click OK.


--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/
Go to Top of Page

kediacommodity1
Starting Member

India
9 Posts

Posted - 03/13/2009 :  12:56:43  Show Profile  Send kediacommodity1 a Yahoo! Message  Reply with Quote
the valu of remote access (mimimum=0, maximum=1, Configer value=1, run value =1)

please suggest if any change

Regrda



quote:
Originally posted by guptam

On the SQL Server in question ..
Launch SSMS and Connect to server.
Start a New Query
Type in "sp_configure 'remote access'"
Press F5 (run).

Alternatively...

On The SQL Server in Question
Launch SSMS and Connect to server.
Right click on server go to Properties.
Click Connections.
Select "Allow remote connections on server".
Click OK.


--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/

Go to Top of Page

guptam
Posting Yak Master

Canada
161 Posts

Posted - 03/13/2009 :  13:09:00  Show Profile  Visit guptam's Homepage  Click to see guptam's MSN Messenger address  Reply with Quote
Those are correct; did you try connecting to your server using SSMS? Instead of using Telnet? All settings seem correct now...

--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/
Go to Top of Page

kediacommodity1
Starting Member

India
9 Posts

Posted - 03/13/2009 :  13:27:05  Show Profile  Send kediacommodity1 a Yahoo! Message  Reply with Quote
i would like to connect databast useing odbc

can you give me your contact number.

regards






quote:
Originally posted by guptam

Those are correct; did you try connecting to your server using SSMS? Instead of using Telnet? All settings seem correct now...

--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/

Go to Top of Page

guptam
Posting Yak Master

Canada
161 Posts

Posted - 03/13/2009 :  14:22:36  Show Profile  Visit guptam's Homepage  Click to see guptam's MSN Messenger address  Reply with Quote
Okay run odbc manager..

Start->Run->odbcad32
Click on System - > Add
Scroll the list find "SQL Native Client", Select it.
Click Finish.
Enter Name "TestODBC", Description "Blank"
Server "yourServerName", click Next
If your server is on domain leave "Integrated WIndows Authentication", Click Next.
(.... If you can talk to your server here your good to go :).)
Select Change the default database to: Look in list find db you need; select it.
Click Next.
Click Finish.
Click Test Data Source... Confirm and click OK.
And Click Ok.


Thanks.


--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/
Go to Top of Page

kediacommodity1
Starting Member

India
9 Posts

Posted - 03/19/2009 :  07:25:03  Show Profile  Send kediacommodity1 a Yahoo! Message  Reply with Quote
same problem

quote:
Originally posted by guptam

Okay run odbc manager..

Start->Run->odbcad32
Click on System - > Add
Scroll the list find "SQL Native Client", Select it.
Click Finish.
Enter Name "TestODBC", Description "Blank"
Server "yourServerName", click Next
If your server is on domain leave "Integrated WIndows Authentication", Click Next.
(.... If you can talk to your server here your good to go :).)
Select Change the default database to: Look in list find db you need; select it.
Click Next.
Click Finish.
Click Test Data Source... Confirm and click OK.
And Click Ok.


Thanks.


--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/

Go to Top of Page

guptam
Posting Yak Master

Canada
161 Posts

Posted - 03/19/2009 :  14:21:03  Show Profile  Visit guptam's Homepage  Click to see guptam's MSN Messenger address  Reply with Quote
Okay this is not making sense ..

1) Your confirmed SQL Server allows remote connections.
2) You confirmed firewall allows port 1433.
3) You confirmed TCP/IP and Named Pipes Protocols are enabled.

Found intersecting article that might be of help:
http://blogs.msdn.com/sql_protocols/archive/2005/12/19/505372.aspx (look at point #3)
http://support.microsoft.com/kb/888228 (Not a cluster or named instance right???)
http://support.microsoft.com/kb/328306 (lists whole hosts of things that can cause issue, have a quick scan through this)....

Thanks.


--
Mohit K. Gupta
B.Sc. CS, Minor Japanese
MCITP: Database Administrator
MCTS: SQL Server 2005
http://sqllearnings.blogspot.com/
Go to Top of Page

jmozko
Starting Member

1 Posts

Posted - 07/01/2014 :  01:26:10  Show Profile  Reply with Quote
Hi:

Here is the solution http://stackoverflow.com/questions/9478957/unable-to-access-an-instance-of-sql-server-2008-r2-remotely

Regards
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.12 seconds. Powered By: Snitz Forums 2000