SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 Other SQL Server Topics (2005)
 Linked Servers Issue (SQL to AS400)
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

chip
Starting Member

USA
14 Posts

Posted - 04/13/2009 :  19:01:31  Show Profile  Reply with Quote
Trying to link an AS400 to a SQL Server 2005 Developer SP2 so that I can access data from both systems. I have loaded the DB2OLEDB and configured it, tested the connection, created packages, and ran a sample query. All that worked. I created a linked Server in SSMS but when I click on the plus sign to open up the Tables (under Linked Servers-->linked server name-->Catalogs, I get the following messages:

Failed to retrieve data for this request. (Microsoft.SqlServer.SmoEnum)

An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

Cannot fetch a row from OLE DB provider "SQL Server" for linked server "(null)". (Microsoft SQL Server, Error: 7330)

Any ideas anyone?

Thanks!!

Chip Dickson
Texas

Edited by - chip on 04/14/2009 18:00:35

Prateekarya2011
Starting Member

1 Posts

Posted - 06/30/2014 :  04:34:58  Show Profile  Reply with Quote
Hii chip i am facing same error, did you got any solution to above mentioned error?
Kindly rply.. ASAP...
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.08 seconds. Powered By: Snitz Forums 2000