SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2008 Forums
 SQL Server Administration (2008)
 Connection issue on SQL Server Enterprise Evaluati
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

mdubey
Posting Yak Master

USA
133 Posts

Posted - 04/22/2009 :  22:36:31  Show Profile  Reply with Quote
Hello All,

Can anyone help me in the connection issue. I have Windows Server 2003 SP2 and I installed SQL 2008 Enterprise Evaluation edition 10.00.1600. I don't had any issue while installing SQL 2008. I also Installed same version of SQL 2008 on my laptop xp professional sp3 without any issue.

I was trying to connect from my laptop server to Windows server SQL Server. It is giving me an error for TCP/IP NP error message. I have checked from Configuration manager All the client protocol is enabled and in order of 1) Shared Memory, 2) TCP/IP and 3)Named Pipe. Still I can't able to figure it out why it is not connecting to the server on the same network.

SQL browser is also running.

Any help would be appreciated.

Manoj
MCP, MCTS

tkizer
Almighty SQL Goddess

USA
37287 Posts

Posted - 04/23/2009 :  00:14:00  Show Profile  Visit tkizer's Homepage  Reply with Quote
Please post the exact error message for starters.

Tara Kizer
Microsoft MVP for Windows Server System - SQL Server
http://weblogs.sqlteam.com/tarad/

Subscribe to my blog

"Let's begin with the premise that everything you've done up until this point is wrong."
Go to Top of Page

mdubey
Posting Yak Master

USA
133 Posts

Posted - 04/23/2009 :  09:25:28  Show Profile  Reply with Quote
Hi Tara,

Thanks for response, I got this error meessage..

"A network-related or instance-specific error occured while establishing a connection to SQL server. The Server was not found or was not accessible. Verify the instance name is correct and that SQL server is configured to allow remote connections. (Provider: Named Pipe Provider, error:40-Cound not open a connection to SQL server)(Microsoft SQL Server, Error:233)"

I am using Servername/Instancename for named instance.

Manoj
MCP, MCTS
Go to Top of Page

mdubey
Posting Yak Master

USA
133 Posts

Posted - 04/23/2009 :  11:11:22  Show Profile  Reply with Quote
I got the resolution. below are the steps I made on my server and It is working fine for me.

You need to check a few things on each server:



DTC Configuration - if you need to allow transactions between the servers.

Click Start and then Click Run
In the Run Dialog box, type dcomcnfg.exe, and then click OK
In the Component Services window, expand Component Services, expand Computers, and then expand My Computer.
Right-click My Computer, and then click Properties.
Select the MSDTC tab, and click Security Configuration.
In the Security Configuration dialog box, click to select the Network DTC Access check box, and select both "Allow Remote Clients" and "Allow Remote Administration"
Under the Transaction Manager Communication group, click to select the Allow Outbound check box and the Allow Inbound check box, and click to choose No Authentication Required or Mutual Authentication..
Click to select Enable XA Transactions.
In the Security Configuration dialog box, click OK. If there is window popping up saying MS DTC service will be restarted, click Yes. Click OK once MSDTC service has been successfully restarted.
In the My Computer Properties dialog box, click OK


SQL Server Network Configuration - to ensure that communication has been enabled on each server.

From Start, go to All Programs -> Microsoft SQL Server 2005 -> Configuration Tools -> SQL Server Configuration Manager
From left panel, click SQL Server 2005 Network Configuration -> Protocols for <INSTANCE> (which is MSSQLSERVER for default, for each of your named instances), from the right panel, and ensure TCP/IP has been enabled for all instances.
Restart SQL Server and Agent services on all changed instances


SQL Server Surface Area Configuration - to ensure named instances can be found via directory search.

From Start, go to All Programs -> Microsoft SQL Server 2005 -> Configuration Tools -> SQL Server Surface Area Configuration.
On the SQL Server 2005 Surface Area Configuration page, click Surface Area Configuration for Services and Connections.
On the Surface Area Configuration for Services and Connections page, check that SQL Server Browser is started, and that the Startup type is "Automatic". Note When you click the Automatic option, the SQL Server Browser service starts automatically every time that you start Microsoft Windows.


This should get you going.



Manoj
MCP, MCTS
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.06 seconds. Powered By: Snitz Forums 2000