SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 Replication (2005)
 MSDTC/RPC issues in in transactional replication w
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

brantj
Starting Member

USA
1 Posts

Posted - 06/24/2010 :  13:48:48  Show Profile  Reply with Quote
First of all, I must admit that this is a cross-post as I'm running out of time to get this issue resolved so I could use all the help I can get.

I have transactional replication with updatable subscriptions setup in SQL Server 2005. Everything works fine except for when i attempt to write to the subscriber database using immediate updating. That is, the update fails because it is unable to complete the update on the publisher database, giving the following error message:

"The RPC security information for the Publisher is missing or invalid. Use sp_link_publication to specify it."



Of course, I ran sp_link_publication and it succeeded but that did not fix the problem. After reading several forum posts dealing with similar problems, I utilized DTCPing (run against the publisher from the subscriber) to test RCP functionality. It failed, giving me the following message:

"1753 (There are no more endpoints available from the endpoint mapper)"

I determined the port that DTCPing was utilizing and used 'portqry' to retrieve its status; which incidentally was "NOT_LISTENING."

Almost all of the forum posts pointed towards a firewall blocking the necessary ports but that simply isn't the case here as the two machines are test boxes and there are no software (Windows firewall, third party, etc) or hardware firewalls between the two. Network DTC is enabled and is setup to allow both inbound and outbound connections and the "no authentication required" radio button is selected. Also, the MSDTC service is set to startup automatically and is running. Both machines are running the latest OS service pack (Windows 2003 SP2) and the latest SQL Server service pack (SQL Server 2005 SP3). Unfortunately, I didn't come across too many instances where this problem was actually solved apart from the firewall resolution.

Any suggestions?

Thanks,
Jonathan
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.06 seconds. Powered By: Snitz Forums 2000