SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 SQL Server Administration (2005)
 Help! can't start SQL Server!!!!!
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Newbie777
Starting Member

20 Posts

Posted - 12/20/2010 :  16:50:57  Show Profile  Reply with Quote
I changed the startup parameters in Config Manager and Now SQL Server won't start up. I tried to change it back but it won't let me in Config Manager, is there any other way I can start it up? Thanks!

tkizer
Almighty SQL Goddess

USA
37129 Posts

Posted - 12/20/2010 :  16:51:39  Show Profile  Visit tkizer's Homepage  Reply with Quote
We'll need the error. Check the AppLog in Event Viewer for the error.

Tara Kizer
Microsoft MVP for Windows Server System - SQL Server
http://weblogs.sqlteam.com/tarad/

Subscribe to my blog
Go to Top of Page

Newbie777
Starting Member

20 Posts

Posted - 12/20/2010 :  17:20:09  Show Profile  Reply with Quote
theres a bunch of errors from the app logs:

sqqgtres: checkservice alive: QueryServiceStatus Failed (status 6),
sqsrvres: online thread error 435 bringing resouce online.
sqsrvres: resutilsstartresource service failed (status 435),
sqsrvres: failed to start mssql$instance1 current state 1
sqsrvres: counld not open errorlong file, operating system error = 3,the system could not find the path specified.
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
37129 Posts

Posted - 12/20/2010 :  17:23:56  Show Profile  Visit tkizer's Homepage  Reply with Quote
It seems you've got an incorrect path specified for the Error Log. You'll need to rectify that in the startup parameters of the service via Configuration Manager.

Tara Kizer
Microsoft MVP for Windows Server System - SQL Server
http://weblogs.sqlteam.com/tarad/

Subscribe to my blog
Go to Top of Page

Newbie777
Starting Member

20 Posts

Posted - 12/21/2010 :  11:16:40  Show Profile  Reply with Quote
I did, I have added the line and ran this in command mode:

sqlservr.exe -sINSTANCE1 ;-eF:\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG

I have verified the errorlog does exist on that drive but I still get the error message:
initerrlog: Could not open error log file Operating system error = 3(The system cannot find the path specified.)
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
37129 Posts

Posted - 12/21/2010 :  11:38:59  Show Profile  Visit tkizer's Homepage  Reply with Quote
Show the entire startup parameter line in the Config Manager.

Tara Kizer
Microsoft MVP for Windows Server System - SQL Server
http://weblogs.sqlteam.com/tarad/

Subscribe to my blog
Go to Top of Page

Newbie777
Starting Member

20 Posts

Posted - 12/21/2010 :  11:47:05  Show Profile  Reply with Quote
do you mean put this in startup param in config manager?

sqlservr.exe -sINSTANCE1 ;-eF:\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG

I also tried this and it didn't work in config manager:
-dF:\Microsoft SQL Server\MSSQL.1\MSSQL\Data\master.mdf;-eF:\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG;-lF:\Microsoft SQL Server\MSSQL.1\MSSQL\Data\mastlog.ldf
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
37129 Posts

Posted - 12/21/2010 :  11:49:32  Show Profile  Visit tkizer's Homepage  Reply with Quote
No, I mean copy/paste what you have in Config Manager into this thread so that we can inspect it. Something is wrong with your startup parameters.

Tara Kizer
Microsoft MVP for Windows Server System - SQL Server
http://weblogs.sqlteam.com/tarad/

Subscribe to my blog
Go to Top of Page

Newbie777
Starting Member

20 Posts

Posted - 12/21/2010 :  11:59:50  Show Profile  Reply with Quote
this is what I pasted into the startup parameter in config manager, then I used the login tab to start the service. but fails

-dF:\Microsoft SQL Server\MSSQL.1\MSSQL\Data\master.mdf;-eF:\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG;-lF:\Microsoft SQL Server\MSSQL.1\MSSQL\Data\mastlog.ldf
===========================================================
this is what i put originally that started the problem:
-c -m -T3608 without the semicolon then shutdown the service.
Go to Top of Page

russell
Pyro-ma-ni-yak

USA
5072 Posts

Posted - 12/21/2010 :  15:29:51  Show Profile  Visit russell's Homepage  Reply with Quote
In regedit navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer\Parameters

Make sure there's nothing else in there. Verify all 3 paths are correct.
Go to Top of Page

Newbie777
Starting Member

20 Posts

Posted - 12/21/2010 :  16:19:32  Show Profile  Reply with Quote
THANK YOU!

This is what's in regedit under parameters

Name Type Data
(Default) REG_SZ (value not set)
SQLArg0 REG_SZ -c -m -T3608

Go to Top of Page

russell
Pyro-ma-ni-yak

USA
5072 Posts

Posted - 12/21/2010 :  16:44:52  Show Profile  Visit russell's Homepage  Reply with Quote
Should look a lot like this:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer\Parameters]
"SQLArg0"="-dC:\\Program Files\\Microsoft SQL Server\\MSSQL.1\\MSSQL\\DATA\\master.mdf"
"SQLArg1"="-eC:\\Program Files\\Microsoft SQL Server\\MSSQL.1\\MSSQL\\LOG\\ERRORLOG"
"SQLArg2"="-lC:\\Program Files\\Microsoft SQL Server\\MSSQL.1\\MSSQL\\DATA\\mastlog.ldf"


Did you get it running now?

What were you doing? Moving the system databases?

Edited by - russell on 12/21/2010 16:47:12
Go to Top of Page

Newbie777
Starting Member

20 Posts

Posted - 12/21/2010 :  16:56:28  Show Profile  Reply with Quote
How do I get it to look like that?

I was trying to move the model database. no it doesn't look like that, it still looks like this:

Name Type Data
(Default) REG_SZ (value not set)
SQLArg0 REG_SZ -c -m -T3608


Thanks.
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
37129 Posts

Posted - 12/21/2010 :  16:57:28  Show Profile  Visit tkizer's Homepage  Reply with Quote
It sounds like he accidentally removed all startup parameters and then put in just the ones needed to start in single user mode. And then realized that was a mistake, but now the registry is messed up. Hand modifying the registry should do the trick.

Tara Kizer
Microsoft MVP for Windows Server System - SQL Server
http://weblogs.sqlteam.com/tarad/

Subscribe to my blog
Go to Top of Page

russell
Pyro-ma-ni-yak

USA
5072 Posts

Posted - 12/21/2010 :  17:39:26  Show Profile  Visit russell's Homepage  Reply with Quote
Yep, that's what it sounds like.

Newbie777. right-click the registry key and choose export. Save it to the desktop or something.

Then, in regedit, delete all of the paramaters. Next type in the correct values. From the looks of your earlier posts, it should be exactly what I posted above, except on your F: drive where I had C:

Leave your -m -c and trace flag out for now. Let's get the SQL Service running 1st.

If all goes well, you can re-add them later.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.08 seconds. Powered By: Snitz Forums 2000