SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 General SQL Server Forums
 New to SQL Server Administration
 Trying to set up web app with MSSQL 2008 Express
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

ignign0kt
Starting Member

3 Posts

Posted - 03/16/2012 :  21:23:40  Show Profile  Reply with Quote
I am trying to set up this web app to connect to MSSQL Express on my desktop to be able to tinker with it.
http://code.google.com/p/server-inventory/

I have the web server running and I'm able to load the webapp, but I cannot get it to connect to the database. SQL is all new to me, so I'm having trouble finding what's wrong.
I installed MSSQL 2008 Express SP3, with Management Studio. This is how the webapp connects:


      <add key="DataSource" value ="DESK\SQLEXPRESS" />
      <add key="UserID" value ="racks" />
      <add key="Password" value ="password" />
      <add key="InitialCatalog" value ="racks" />


Firstly, I'm not sure what to put for the InitialCatalog part, I just left it the same as the coder had it.

I have added the racks login with Management Studio (under Security > Logins). The server is running, however when the app tries to connect to the DB, this is one of the errors I'm getting:

A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.)

Shared Memory, Naming Pipes, and TCP are enabled

I checked the server log after trying to connect, and I see this:

Login failed for user 'racks'. Reason: failed to open the explicitly specified database. [CLIENT: <local machine>]
Error: 18456, Severity 14, State: 38

The developer has no installation instructions and I doubt they would include MSSQL setup instructions anyway lol

I would love some help

Edited by - ignign0kt on 03/16/2012 21:38:15

ignign0kt
Starting Member

3 Posts

Posted - 03/17/2012 :  16:15:55  Show Profile  Reply with Quote
I have created a database called racks, made a user called racks, and made it "db_owner".
Now I get this error:

System.Data.SqlClient.SqlException: Invalid object name 'server_ips'.
   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
   at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
   at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async)
   at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
   at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
   at ASP.import_aspx.ProcessRequest() in c:\Abyss Web Server\htdocs\import.aspx:line 57


Not sure what this means

Edited by - ignign0kt on 03/17/2012 17:29:48
Go to Top of Page

SwePeso
Patron Saint of Lost Yaks

Sweden
30276 Posts

Posted - 03/17/2012 :  18:21:46  Show Profile  Visit SwePeso's Homepage  Reply with Quote
What happens on line 57?



N 56°04'39.26"
E 12°55'05.63"
Go to Top of Page

GilaMonster
Flowing Fount of Yak Knowledge

South Africa
4507 Posts

Posted - 03/17/2012 :  18:22:07  Show Profile  Visit GilaMonster's Homepage  Reply with Quote
Your code is referencing an object called server_ips, but the object does not exist.

p.s. db_owner is a very poor security practise. Read up on the principal of least privilege.

--
Gail Shaw
SQL Server MVP
Go to Top of Page

ignign0kt
Starting Member

3 Posts

Posted - 03/17/2012 :  19:26:34  Show Profile  Reply with Quote
quote:
Originally posted by GilaMonster

Your code is referencing an object called server_ips, but the object does not exist.

p.s. db_owner is a very poor security practise. Read up on the principal of least privilege.



Not really concerned about this at the moment. This is just on my home desktop because I want to get the webapp running to test. I'll look into that later


I think the error was just becuase of bad input files.
Now the import says "Finished", but it didn't add anything
Now I'm stuck and making this topic was useless cause there's not much you can do lol. Unless you want to download the app and set it up youreslf ;

Edited by - ignign0kt on 03/17/2012 19:44:55
Go to Top of Page

GilaMonster
Flowing Fount of Yak Knowledge

South Africa
4507 Posts

Posted - 03/18/2012 :  08:37:46  Show Profile  Visit GilaMonster's Homepage  Reply with Quote
In my experience people that start with lax security setup because they just want to get stuff working also end with lax security setups because there was no time (or enthusiasm) for fixing it. Dom stuff right to start with rather than planning to fix/learn better later.

As for the import, without a lot more info I can't offer any help.

--
Gail Shaw
SQL Server MVP
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.08 seconds. Powered By: Snitz Forums 2000