SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 Replication (2005)
 Replication went to out of sync
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

govthamb
Starting Member

India
27 Posts

Posted - 01/31/2013 :  08:10:03  Show Profile  Reply with Quote
We have an issue in Transactional Replication which is configured in our environment.

As part of compliance we have applied OS level patches and rebooted the SQL server, post reboot all SQL services and Log Reader agents etc are back to running state.

Based on the replication monitor observed that articles which are in replication are not updated from Publisher to Subscriber, checked and found that LOG reader agent is in running status only, no specific error found in replication monitor, job history, event viewer etc..

Restarted the Log Reader Agent and automatically replication is in sync again.

Client wants to know RCA, why replication out of sync even though Jobs & Log reader agent is running fine.

Need your help in this regard.

russell
Pyro-ma-ni-yak

USA
5072 Posts

Posted - 01/31/2013 :  09:57:50  Show Profile  Visit russell's Homepage  Reply with Quote
There is an issue with Replication Monitor, where after a reboot it misreports undistributed commands (shows a number greater than 0 when in fact there are none). Restarting the distribution agent solves it. If you have many publications, easier to just restart SQL Agent on the distributor.

So probably, you were in synch the whole time, but ReplMon reported otherwise.
Go to Top of Page

govthamb
Starting Member

India
27 Posts

Posted - 01/31/2013 :  11:30:30  Show Profile  Reply with Quote
Thanks Russell for the information, is there any MS article which supports this issue with Replication Monitor, so that we can provide the same info to our client as well.
Go to Top of Page

russell
Pyro-ma-ni-yak

USA
5072 Posts

Posted - 01/31/2013 :  14:30:45  Show Profile  Visit russell's Homepage  Reply with Quote
Not that I've seen. I know this from years of experience. ReplMon is quick and convenient, but should not be relied upon as your only tool for replication monitoring.

Anyone administering replication should start here
Go to Top of Page

govthamb
Starting Member

India
27 Posts

Posted - 02/01/2013 :  08:18:56  Show Profile  Reply with Quote
Thanks Russel for the info.

We have observed several times a scenario where replication monitor is showing unditributed commands as 0, but when we check manually, records in publisher and subscriber are not matching. Again we need to restart the Log reader agent to make the data in sync. Is this onle of the bug in replication monitor or are we missing anything from our end.

Please suggest.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.04 seconds. Powered By: Snitz Forums 2000