SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2008 Forums
 Other SQL Server 2008 Topics
 OraOleDB.Oracle Connection
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

keith2601
Starting Member

7 Posts

Posted - 02/15/2013 :  08:54:35  Show Profile  Reply with Quote
I had a nightly SSIS package running on Server 2008 R2 that used the Oracle Provider for Ole DB. We have the Oracle Database as a linked server and the package was running fine. One night a couple of weeks ago, we got a error that the SQL server could not initialize the data source object of Ole DB Provider "OraOleDB.Oracle" for linked server "NAME". Microsoft SQL Error 7399.

We had put a patch on the evening before and attributed that to getting the error. We unistalled Oracle and reinstalled it and set up the TNSNames file again. And the package started running again.

Last night, the same thing happened, however, I have been told that no changes were made to the SQL server or to Oracle.

Has anybody else had this issue and knows what causes this? Obviously to fix it, we will uninstall Oracle and reinstall it, however, we need to know how to prevent this from happening in the future.

Thanks for any help.
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.17 seconds. Powered By: Snitz Forums 2000