SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 SQL Server Administration (2005)
 OLE DB provider "OraOLEDB.Oracle" for linked serve
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

avi126e
Starting Member

1 Posts

Posted - 02/19/2013 :  05:57:36  Show Profile  Reply with Quote
Please help us on the below issue
We have a linked server which fetches data from Oracle 11.2.0 (which was migrated from Oracle 10g to Oracle 11g and platform also got migrated to exadata) to SQL server(SQL Server 2005 SP2) . Using openquery when we try to fetch data we are facing the below issue

“OLE DB provider "OraOLEDB.Oracle" for linked server "OFAP" returned message "ORA-12592: TNS:bad packet".

If we run the same query by removing 2 columns containing Varchar (240), the data is coming properly within 5 secs.
Did anyone came across this error before & how to troubleshoot .We really appreciated with all your help

Below are the steps we have performed to verify manually
1) We have extracted the query from stored procedure and executed on SQL server where it is getting hanged after fetching 11K records (Out of 26 K records).
2) The same query when executed in Oracle server (OFAP) was giving the result in 10 sec with a record count of 26K.
3) We have removed two columns from the select list which contains the major data size (Varchar 250) and was executed on SQL server Instance which fetched 26 K records in 11 to 15 sec.
3) On further dig-up we have used Substring to limit the character from the two columns to return 12 characters, 12 K records were fetched before the session got hanged up.
4) Network packet size in SQL Server :- We have increased the packet size from 4096 to 8192.
5) We have installed Oracle 11.2.0.3 64 bit on SQL Server Physical Box.

sqlcentauri
Starting Member

1 Posts

Posted - 07/07/2013 :  07:30:05  Show Profile  Reply with Quote
Hello,
I'm having a similar problem. It looks like there is something like a buffer threshlod cutting the amount of data that can travel to SQL Server box.
Have you managed to find a solution?
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.03 seconds. Powered By: Snitz Forums 2000