SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 General SQL Server Forums
 New to SQL Server Programming
 Model Table or Procedure not updating
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

byte
Starting Member

4 Posts

Posted - 03/09/2013 :  13:13:29  Show Profile  Reply with Quote
Hi all,

I'm fairly new at all this but I know a little, I've recently taken over our database from a guy who designed it and I've been tasked with adding a part name to our database. It is aspx format and I've managed to add the line item to the aspx file:

<asp:ListItem Value="24">Wipers</asp:ListItem>

I've also added Wipers to the table in sql. That part seems OK.

Now when I open a ticket for a repair the part name Wipers is not shown against the part name field but the value 24 is shown and I cannot work out why it is not picking up the value I added Wipers.

I hope this makes sense and I'm sure it is something really simple but I'm tearing my hair out here :O

Thanks for any help in advance :)

Thanks,

byte

visakh16
Very Important crosS Applying yaK Herder

India
52317 Posts

Posted - 03/09/2013 :  14:16:28  Show Profile  Reply with Quote
value is the one that gets saved in db. the description (Wipers) is only for display only. if you want value also same as desc use

<asp:ListItem Value="Wipers">Wipers</asp:ListItem>

------------------------------------------------------------------------------------------------------
SQL Server MVP
http://visakhm.blogspot.com/

Go to Top of Page

byte
Starting Member

4 Posts

Posted - 03/09/2013 :  14:35:12  Show Profile  Reply with Quote
Thanks for your reply but unfortunately the database set up is not quite like this. For example the front end has this line:

<asp:ListItem Value="24">Wipers</asp:ListItem>

With 1-24 and their is a sql table called TblPartList with 3 columns PartID PartName and Discontinued now 24 is populated in PartID and PartName has Wipers typed in. The bit that gets screwed up is when I create a new ticket where it picks up the Part name and for some reason uses the PartID 24...I have 23 other part names and they all list perfectly but I do not know if there is a sql procedure I have to further update as the new ticket is looking.

Thanks,

byte
Go to Top of Page

visakh16
Very Important crosS Applying yaK Herder

India
52317 Posts

Posted - 03/10/2013 :  04:10:01  Show Profile  Reply with Quote
sounds like problem with backend code logic then. if you can post code behind, somebody might be able to help

------------------------------------------------------------------------------------------------------
SQL Server MVP
http://visakhm.blogspot.com/

Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.11 seconds. Powered By: Snitz Forums 2000