Please start any new threads on our new site at http://forums.sqlteam.com. We've got lots of great SQL Server experts to answer whatever question you can come up with.

Our new SQL Server Forums are live! Come on over! We've restricted the ability to create new threads on these forums.

SQL Server Forums
Profile | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 General SQL Server Forums
 New to SQL Server Programming
 Microsoft.SqlServer.Replication.ComErrorException;
 Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

JShann
Starting Member

1 Posts

Posted - 05/24/2013 :  12:52:39  Show Profile  Reply with Quote
Hello,

I have a quick question that I have really been struggling with as of late. I'm going to keep it simple. I am developing an application that uses a two databases running different types of Sql Server, one 32-bit and the other 64 bit. Basically, I need to build my application using Configuration properties of "x86" because accessing the 32-bit database has been deemed more important. The problem occurs when accessing the 64-bit database, I receive the exception Microsoft.SqlServer.Replication.ComErrorException, "class not registered". Unfortunately I can't use the most suggested solution of changing the build properties to "Any CPU" because it breaks access to the 32-bit database. Does anyone have an idea about how I would fix this in another manner? I've tried adding references to Microsoft.SqlServer.Replication.dll, Microsoft.SqlServer.Rmo.dll among others and still no luck. Any advice is appreciated and I thank you in advance.

  Previous Topic Topic Next Topic  
 Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.05 seconds. Powered By: Snitz Forums 2000