SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2008 Forums
 Other SQL Server 2008 Topics
 Prevent SQL from Autopopulating
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

cstokes91
Yak Posting Veteran

USA
59 Posts

Posted - 10/10/2013 :  12:56:06  Show Profile  Reply with Quote
Hey,

This isn't a super big deal but it is more of a nuisance that anything else... When I am typing out a query and am typing in a case statement like


case when X is not null then Y end 


when I type is it automatically fills out isDate when I hit space to go to the next word... is there anyway to just specifically stop it from doing that for that keyword (is)? Also, case is another word I would like to prevent it from autopopulating different options.

Edited by - cstokes91 on 10/10/2013 13:02:19

djj55
Constraint Violating Yak Guru

USA
324 Posts

Posted - 10/10/2013 :  13:29:38  Show Profile  Reply with Quote
Turn off IntelliSense.

Or do what I do and type isnot as one word then add the space

djj
Go to Top of Page

cstokes91
Yak Posting Veteran

USA
59 Posts

Posted - 10/10/2013 :  13:38:56  Show Profile  Reply with Quote
Hmm,

Neither of those is a perfect solution... IntelliSense can be useful so I don't want it to be completely disabled... I was just hoping to disable a few choice keywords such as or, case, and is.

And if I did that then I would still have to press the left arrow three times so it would be quicker to just hit ESC (so I am still stuck at square one).

I guess what I am looking for is something like what is in Microsoft Word with the AutoCorrect options.
Go to Top of Page

djj55
Constraint Violating Yak Guru

USA
324 Posts

Posted - 10/10/2013 :  15:25:10  Show Profile  Reply with Quote
Since Microsoft Word is an unrealted company to Microsoft SQL Server, they do not share information. :-)

I do not know what to tell you. My trouble is when typing CAST(myval AS DATE) the Intellisense puts in DATEADD. :-(

Let me know if you come across a solution.

By-the-way I am only half joking when say in Word and SQL do not talk.

djj
Go to Top of Page

robvolk
Most Valuable Yak

USA
15663 Posts

Posted - 10/10/2013 :  21:34:25  Show Profile  Visit robvolk's Homepage  Reply with Quote
quote:
Originally posted by djj55
By-the-way I am only half joking when say in Word and SQL do not talk.
That's true, they probably do talk now and then. It's the Sharepoint, BizTalk, and Project Server folks who never talk to the SQL Server team.

/not actually joking, they really don't
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.06 seconds. Powered By: Snitz Forums 2000