Please start any new threads on our new site at We've got lots of great SQL Server experts to answer whatever question you can come up with.

Our new SQL Server Forums are live! Come on over! We've restricted the ability to create new threads on these forums.

SQL Server Forums
Profile | Active Topics | Members | Search | Forum FAQ
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 SQL Server Administration (2005)
 Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Posting Yak Master

193 Posts

Posted - 10/29/2013 :  18:31:28  Show Profile  Reply with Quote
Hi Experts,
Need a small suggestion on the below issue.
I have observer that log file size is around 100GB and the log_reuse_wait_desc shows as Replication and REP_ database is in simple recovery model.
First time I am seeing Snapshot replication will also cause log to wait on replication. We tried several ways to mark transactions as repl done but no luck and the log reuse wait still shows as replication.
When I run dbcc opentran it is showing as below.
Replicated Transaction Information:
Oldest distributed LSN : (0:0:0)
Oldest non-distributed LSN : (190181:4701335:41)
So the Tlog was not truncating because of oldest non-distributed LSN.
Any thought on this would be appreciated

Thank You All In Advance

Almighty SQL Goddess

38200 Posts

Posted - 10/30/2013 :  16:08:28  Show Profile  Visit tkizer's Homepage  Reply with Quote
You need to investigate why replication is not working or remove replication temporarily. You can't clear the log until replication is fixed. What does replication monitor show?

Tara Kizer
SQL Server MVP since 2007
Go to Top of Page
  Previous Topic Topic Next Topic  
 Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2019 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.02 seconds. Powered By: Snitz Forums 2000