SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 General SQL Server Forums
 New to SQL Server Administration
 SQLServer 2008R2 install but SQLService wont start
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

asp__developer
Posting Yak Master

108 Posts

Posted - 11/07/2013 :  08:31:07  Show Profile  Reply with Quote
I already have SQL Server 2012 running on my computer without any problem (Instance 1)

Now I wanted to have 2008 version to so I installed SQL Server 2008 R2 also (named it: Instance2008).

Now the SQL Server (Instance 2008) in the services won't start.

I get error saying:
windows could not start the sql server (Instance2008) service on local computer - code 10048


I looked everywhere online and it seems like it has something to do with the login user.

Question 1) - what is the password for log on (NT Service\ Instance 2008) as I see in my case the domain/user so I guess I need to change it to NT Service but I don't know the password ?

Question 2) - Is it possible to run sql server 2012 and 2008 r2 on same computer at the first place ? as both are using 1433 port in TCP/IP settings. ?

Edited by - asp__developer on 11/07/2013 10:12:42

tkizer
Almighty SQL Goddess

USA
35937 Posts

Posted - 11/07/2013 :  12:20:42  Show Profile  Visit tkizer's Homepage  Reply with Quote
Using a domain user is fine. Have you looked in the application log for the error for why the service won't start?

Yes you can run both on the same server. I have some test servers with 2005, 2008 R2 and 2012. No issues.

You can't use the same port for both instances. Switch the 2008 instance to a different port.





Tara Kizer
SQL Server MVP since 2007
http://weblogs.sqlteam.com/tarad/
Go to Top of Page

asp__developer
Posting Yak Master

108 Posts

Posted - 11/07/2013 :  13:03:41  Show Profile  Reply with Quote
I just changed the port from 1433 to 1435 for 2008 instance and it worked.

But now the problem is..I am able to open sql server but when I try to connect to this sql server 2008 instance from other machine over the same network, I am not able to do that.

I am able to connect to 2012 instance without any problem.

I have also added a rule in the network firewall so allow all the inbound connections.

Edited by - asp__developer on 11/07/2013 13:05:17
Go to Top of Page

asp__developer
Posting Yak Master

108 Posts

Posted - 11/07/2013 :  13:04:03  Show Profile  Reply with Quote
2012 instance and connection from over computers on same network working fine - YES

2008 R2 service started and running fine after chaning the port to 1434 - YES

I am able to open and run sql server 2008 management studio and access databases - YES

I created UDL file to test the connection, I am able to establish connection successfully on same computer on which I have sql server 2008 rs - YES

In services, I see 2 sql server services (2012 instance and 2008 instance) - both running fine- YES

There is only 1 browser service for sql in services, running fine- YES

Connection to sql server 2008 r2 instance from other machine on same network (after opening the post in firewall) - NOT SUCCESSFUL / NOT WORKING
Go to Top of Page

asp__developer
Posting Yak Master

108 Posts

Posted - 11/07/2013 :  13:05:04  Show Profile  Reply with Quote
Ok, a long shot but worth trying. I tired this - Click Start > Run > Notepad c:\windows\system32\drivers\etc\services

I just ran the command and I don't see 1435:

ms-sql-s 1433/tcp #Microsoft-SQL-Server
ms-sql-s 1433/udp #Microsoft-SQL-Server
ms-sql-m 1434/tcp #Microsoft-SQL-Monitor
ms-sql-m 1434/udp #Microsoft-SQL-Monitor
ms-sna-server 1477/tcp
ms-sna-server 1477/udp




I added this to the list:


ms-sql-s 1435/udp #Microsoft-SQL-Server
ms-sql-s 1435/tcp #Microsoft-SQL-Server
ms-sql-m 1435/udp #Microsoft-SQL-Monitor
ms-sql-m 1435/tcp #Microsoft-SQL-Monitor
Go to Top of Page

asp__developer
Posting Yak Master

108 Posts

Posted - 11/07/2013 :  13:05:37  Show Profile  Reply with Quote
Rebooted and restarted sql service again just for making sure everything is refreshed,

Tried connectince from other machine on same network to 2012 instance - SUCCESSFUL

Tried connecting from other machine on same network to 2008 instance - NOT SUCCESSFUL

Just ran the cmd command for port list and got this (we not have the 1345 but still not working ?)
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
35937 Posts

Posted - 11/07/2013 :  13:20:42  Show Profile  Visit tkizer's Homepage  Reply with Quote
Try connecting with ServerName,PortNumber. If that works, then you can either choose to connect with that or add a SQL alias to the client machine.

Tara Kizer
SQL Server MVP since 2007
http://weblogs.sqlteam.com/tarad/
Go to Top of Page

asp__developer
Posting Yak Master

108 Posts

Posted - 11/07/2013 :  13:41:03  Show Profile  Reply with Quote
Could you please advise, how to do that ? I am not sure how to do either of those two things.
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
35937 Posts

Posted - 11/07/2013 :  14:15:05  Show Profile  Visit tkizer's Homepage  Reply with Quote
On the machine you are getting that error, instead of using ServerName\InstanceName, use ServerName,PortNumber. An example would be: Server1\Instance1 and switch it to Server1,1435

Tara Kizer
SQL Server MVP since 2007
http://weblogs.sqlteam.com/tarad/
Go to Top of Page

asp__developer
Posting Yak Master

108 Posts

Posted - 11/07/2013 :  14:27:44  Show Profile  Reply with Quote
Test 1:

before trying to use command prompt, I tried server name,port using visual studio server object explorer in visual studio and it worked !!!

SERVERNAME, 1435 - working

Now any idea why instance name is not working like this ? Servername\instance2008 ?


Test 2:

I did using the command prompt also and I was able to get into the database without any error

Edited by - asp__developer on 11/07/2013 14:51:04
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
35937 Posts

Posted - 11/07/2013 :  15:33:21  Show Profile  Visit tkizer's Homepage  Reply with Quote
The client machine was unable to figure out what port the instance is listening on. This could be due to firewall issues, browser service issues, etc.

But just create a SQL alias to get around this problem. I find it easiest to do this in the registry. Add the following key to both locations

String value: ServerName\InstanceName
Value data: DBMSSOCN,ServerName,1435

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\Client\ConnectTo
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MSSQLServer\Client\ConnectTo

You will likely need to add the ConnectTo key to both locations.

Tara Kizer
SQL Server MVP since 2007
http://weblogs.sqlteam.com/tarad/
Go to Top of Page

asp__developer
Posting Yak Master

108 Posts

Posted - 11/07/2013 :  15:48:49  Show Profile  Reply with Quote
could you please advise me how to create alias for this as I don't want to mess up anything in the registry ?
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
35937 Posts

Posted - 11/07/2013 :  19:07:58  Show Profile  Visit tkizer's Homepage  Reply with Quote
All of the info is in my last reply.

Tara Kizer
SQL Server MVP since 2007
http://weblogs.sqlteam.com/tarad/

Edited by - tkizer on 11/07/2013 19:08:12
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.14 seconds. Powered By: Snitz Forums 2000