Please start any new threads on our new site at We've got lots of great SQL Server experts to answer whatever question you can come up with.

Our new SQL Server Forums are live! Come on over! We've restricted the ability to create new threads on these forums.

SQL Server Forums
Profile | Active Topics | Members | Search | Forum FAQ
Register Now and get your question answered!
Save Password
Forgot your Password?

 All Forums
 Development Tools
 Reporting Services Development
 cannot configure reporting services
 Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Constraint Violating Yak Guru

367 Posts

Posted - 12/14/2005 :  19:24:31  Show Profile  Reply with Quote
Hi friends
am having problem configuring Reporting services (sql server 2005 standard edition) on Win2003 server. am getting error when setting web serivice identity in reporting configuration tool.
the error log says
" ReportservicesConfigUI.WMIProvider.WMIProviderException: An unknown error has occured in the WMI Provider .Error code 80070568
at ReportServicesConfigUI.WMIProvider.RSReportServerAdmin.setwebserviceIdentity(string Applicationpool) "

any ideas how to resolve this ??

Starting Member

1 Posts

Posted - 02/04/2006 :  09:49:25  Show Profile  Reply with Quote

This fixed the probelm for me.
Go to Top of Page

Constraint Violating Yak Guru

367 Posts

Posted - 02/06/2006 :  15:06:04  Show Profile  Reply with Quote
Thanks mate.will give it a try

Go to Top of Page

Starting Member

5 Posts

Posted - 03/06/2006 :  06:55:22  Show Profile  Visit rpallas's Homepage  Reply with Quote
Hi, this problem is identical to a problem i am having. I have followed the link posted, and carried out the instructions - i.e. added IWAM_computername (but with the actual computer name) to the rsreportserver.config file but i am still getting the same error.

I have restarted the SQL Reporting Service and refreshed the details in the RS Configuration Manager. I have also restarted the server itself, but still no luck.

Anyone got any ideas?

Thank you


Edited by - rpallas on 03/06/2006 06:57:46
Go to Top of Page

Starting Member

1 Posts

Posted - 06/21/2007 :  11:23:48  Show Profile  Reply with Quote
I had the same problem. It seems that the Virtual directories are non existent. Even though the “Reporting Services Configuration” tool reports them as ok.

Open the “Reporting Services Configuration” tool.
Click on the “Report Server Virtual Directory” button on the left.
Check the “Apply default settings” check box on the right.
Click the “New” button.
Click the “Apply“ button at the bottom of the page.

Click on the “Reports Manager Virtual Directory” button on the left.
Repeat the process as described above. And confirm by Clicking the “Apply“ button at the bottom of the page.

Restart the SQL Report Service.

This should fix your problem.

Dexter J Le Blanc Jr.
Go to Top of Page
  Previous Topic Topic Next Topic  
 Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.06 seconds. Powered By: Snitz Forums 2000