SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2000 Forums
 SQL Server Administration (2000)
 Changing SQL Server 2005 language
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

nmg196
Yak Posting Veteran

United Kingdom
70 Posts

Posted - 03/08/2006 :  05:58:24  Show Profile  Visit nmg196's Homepage  Send nmg196 an ICQ Message  Reply with Quote
Hi,

I have just installed SQL Server 2005 Developer Edition on our development server, but under the properties, it says "Language (United States)". How can I change this setting? I am in the UK and I wish it to have United Kingdom defaults. We have had this problem in the past and we even have some software which physically won't install if the SQL Server locale does not match the operating system locale.

Can somebody please explain where this option is configured in SQL 2005.

Also, is it possible to install SQL Server Management Studio on my workstation? I installed the client utilities but it only seemed to install SQL Server Configuration Manager.



Thanks,

Nick...

Tahsin
Starting Member

USA
34 Posts

Posted - 03/08/2006 :  11:50:03  Show Profile  Reply with Quote
I don't think that's the location but, rather, the language property. It's simply stating that your default language is us_english. You can change the language to British (British English) if you want.

Run the following:
EXEC sp_configure 'default language', 23 
RECONFIGURE


Run to verify:
SELECT @@language, @@langid

Edited by - Tahsin on 03/08/2006 11:56:12
Go to Top of Page

nmg196
Yak Posting Veteran

United Kingdom
70 Posts

Posted - 03/08/2006 :  11:57:49  Show Profile  Visit nmg196's Homepage  Send nmg196 an ICQ Message  Reply with Quote
If I run SELECT @@language, @@langid it says "us_english" even after running sp_configure 'default language', 23.

According to sys.syslanguages, 23 *IS* British English. But the server still reports it's running US English.

It also still seems to want US date format for queries. Surely theres a way to change this?!

Edited by - nmg196 on 03/08/2006 12:28:44
Go to Top of Page

Tahsin
Starting Member

USA
34 Posts

Posted - 03/08/2006 :  14:54:46  Show Profile  Reply with Quote
You're right ... that's so weird. I changed it on my server and it shows what you just said. Something else that is weird is that when you run sp_configure without any parameters, it shows that the default language has changed to 23, so I am not sure what's going on.
Go to Top of Page

Michael Valentine Jones
Yak DBA Kernel (pronounced Colonel)

USA
7020 Posts

Posted - 03/08/2006 :  16:19:29  Show Profile  Reply with Quote
Did you run the RECONFIGURE command?

You can read about RECONFIGURE in SQL Server Books Online.

CODO ERGO SUM
Go to Top of Page

nmg196
Yak Posting Veteran

United Kingdom
70 Posts

Posted - 03/08/2006 :  17:03:26  Show Profile  Visit nmg196's Homepage  Send nmg196 an ICQ Message  Reply with Quote
Yes, but running it doesn't seem to make any difference. It still seems impossible to change the default language.
Go to Top of Page

Michael Valentine Jones
Yak DBA Kernel (pronounced Colonel)

USA
7020 Posts

Posted - 03/08/2006 :  17:32:09  Show Profile  Reply with Quote
It sounds like you forgot to change the default lanquage for each login.


CODO ERGO SUM
Go to Top of Page

nmg196
Yak Posting Veteran

United Kingdom
70 Posts

Posted - 03/08/2006 :  18:29:00  Show Profile  Visit nmg196's Homepage  Send nmg196 an ICQ Message  Reply with Quote
I've changed it for sa, and as it's a new server that's pretty much the only login.
Go to Top of Page

Michael Valentine Jones
Yak DBA Kernel (pronounced Colonel)

USA
7020 Posts

Posted - 03/08/2006 :  19:01:15  Show Profile  Reply with Quote
Does that mean it is OK now?

If not, what does this show you?

select @@LANGUAGE

select name, language from master.dbo.syslogins

exec sp_configure 'default language'



CODO ERGO SUM

Edited by - Michael Valentine Jones on 03/08/2006 19:08:31
Go to Top of Page

nmg196
Yak Posting Veteran

United Kingdom
70 Posts

Posted - 03/09/2006 :  04:38:07  Show Profile  Visit nmg196's Homepage  Send nmg196 an ICQ Message  Reply with Quote
SELECT @@language, @@langid
gives:
us_english 0

exec sp_configure 'default language'
gives:
default language 0 9999 23 23

So it appears to be British English, but the server still shows it as being US English on the properties page as shown in my screenshot above. The server still expects dates to be in US format.

I think the commmand above only changes the default language for logins - not the main setting for SQL Server itself (ie the value shown on my screenshot).

Go to Top of Page

Tahsin
Starting Member

USA
34 Posts

Posted - 03/09/2006 :  10:15:35  Show Profile  Reply with Quote
To change the default language of a login, you can either use sp_defaultlanguage or

ALTER LOGIN sa WITH DEFAULT_LANGUAGE = British;
GO

You can check the default language of your logins by going to Management Studio -> Security -> Logins and right clicking on sa and checking the default language

- Tahsin
Go to Top of Page

nmg196
Yak Posting Veteran

United Kingdom
70 Posts

Posted - 03/10/2006 :  05:03:02  Show Profile  Visit nmg196's Homepage  Send nmg196 an ICQ Message  Reply with Quote
I have received a reply from Microsoft that says that SQL Server (when installed on a British English machine) is locked down to US English and there's no way to change it to use UK English. You can change it for individual logins, but I've found this doesn't seem to work all the time. Great...


Edited by - nmg196 on 03/10/2006 05:03:29
Go to Top of Page

dmcmoran
Starting Member

4 Posts

Posted - 07/08/2006 :  21:34:17  Show Profile  Reply with Quote
I don't know if any of you guys have managed to get SQL 2005 Express running as UK English, but I have. NO JOKE.

If your interested in knowing how, please post and I'll write it up. I'd do it now but it involves a reg hack and I need my bed!
Go to Top of Page

mma
Starting Member

Australia
2 Posts

Posted - 07/26/2006 :  06:30:33  Show Profile  Reply with Quote
I would greatly appreciate know kno wyou got it working on SQL Server Express. I am having all the same dramas mentioned below in being able to use local date formats for the Australian machine ( uses british date formats)

Thanks in advance
Matt


quote:
Originally posted by dmcmoran

I don't know if any of you guys have managed to get SQL 2005 Express running as UK English, but I have. NO JOKE.

If your interested in knowing how, please post and I'll write it up. I'd do it now but it involves a reg hack and I need my bed!

Go to Top of Page

dmcmoran
Starting Member

4 Posts

Posted - 07/28/2006 :  18:08:44  Show Profile  Reply with Quote
First off: BACKUP YOUR SERVER/REGISTRY before proceding with this hack, especially if it's a production box!

I take NO responsibility for any outages, server failures or any other problems that may arise from this hack. As is stated elsewhere in this topic, Microsoft say it can't be done (although I'm pretty sure they know it can!) so Microsoft WILL NOT provide technical support for any problems.

Right. There are 3 keys that need to be changed to ensure the SQL server and clients connect with your default language.

1.Navigate to http://msdn2.microsoft.com/en-us/library/ms190303.aspx

Find your language (use the codes under Windows LCID), e.g. for British English use code 2057.

2.You may want to stop the SQL services. I didn't but my server is a rag-tag beta box that is rebuilt once every week!

Open regedit, and find the following 3 keys:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\90\Tools\ClientSetup\CurrentVersion]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\90\Tools\Setup

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.1\Setup]

In these 3 keys you'll find the language settings. It's DWORD so when you edit the key, change to Decimal and put your language code in.

3.Once done, either restart the SQL services or restart the server (if possible). Start management studio and under 'YOURSQLSERVER' properties you should now see the Language you want.
Go to Top of Page

mma
Starting Member

Australia
2 Posts

Posted - 08/09/2006 :  05:14:08  Show Profile  Reply with Quote
Thanks very much for your help. The hack worked well.

Go to Top of Page

mr_point
Starting Member

United Kingdom
1 Posts

Posted - 10/18/2007 :  05:25:43  Show Profile  Reply with Quote
Hi Everyone, just to let you know regards the above hack that it may also be necessary to change the language property of one further registry key, that being:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer\CurrentVersion]

Exactly the same way as detailed above. It took me doing that to finally resolve my language issues, but ta for the lead!

~LS
Go to Top of Page

stkaye
Starting Member

1 Posts

Posted - 07/31/2008 :  10:16:36  Show Profile  Visit stkaye's Homepage  Reply with Quote
Have you not tried

SET Language British

This still wont change the value in the properties page but if you now run

select @@Language, @@Langid

you will get

British 23
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.12 seconds. Powered By: Snitz Forums 2000