SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2000 Forums
 SQL Server Administration (2000)
 Can't 'find' my Australian server
 New Topic  Reply to Topic
 Printer Friendly
Next Page
Author Previous Topic Topic Next Topic
Page: of 2

mark1504
Posting Yak Master

United Kingdom
103 Posts

Posted - 09/26/2006 :  15:25:50  Show Profile  Visit mark1504's Homepage  Send mark1504 a Yahoo! Message  Reply with Quote
Suddenly last week, I became unable to log into the SQL server space I use for the Australian version of my website.

'Specified SQL Server not found' is the error in both QA and EM, and the error is the same on two different PCs I use, so I feel I can discount any installation issues, corruption or setting changes.

I'm continuing to access my server spaces in the UK and USA just fine, therefore I'm pretty sure it's not an issue at my end.

However the Australian host thinks it's my problem, and says QA works OK for him. I'm stuck. I now have a site which I can't access, although it's working fine serving data to my website.

I should add that My USA and UK hosts use 'named pipes' whereas the Australian host doesn't. (In fact he didn't know it was possible.)

Any suggestions? I'll try anything within reason. What should I say to my Aussie host?

Regards
Mark

X002548
Not Just a Number

15586 Posts

Posted - 09/26/2006 :  15:28:37  Show Profile  Reply with Quote
A dingo ate your server

You need to contact the provider and find out what changed?

Can you ping the box? If so you might want to try and set up an alias



Brett

8-)

Hint: Want your questions answered fast? Follow the direction in this link
http://weblogs.sqlteam.com/brettk/archive/2005/05/25/5276.aspx

Add yourself!
http://www.frappr.com/sqlteam

Edited by - X002548 on 09/26/2006 15:33:40
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
36949 Posts

Posted - 09/26/2006 :  15:30:23  Show Profile  Visit tkizer's Homepage  Reply with Quote
Well pinging probably won't work if there is a firewall in between like there usually is between the web server and the database server. But just because you can't ping it, doesn't mean that you can't connect to it.

Find out from the host what port the SQL Server is listening on. Then use TCP/IP via an alias to connect to the database server. This is done via Client Network Utility.

Tara Kizer
Go to Top of Page

X002548
Not Just a Number

15586 Posts

Posted - 09/26/2006 :  15:34:58  Show Profile  Reply with Quote
Yeah, what she said....but something changed somewhere, either on your side or there's...I'mmmmmmmmmmmmmmmmm guessing your side



Brett

8-)

Hint: Want your questions answered fast? Follow the direction in this link
http://weblogs.sqlteam.com/brettk/archive/2005/05/25/5276.aspx

Add yourself!
http://www.frappr.com/sqlteam
Go to Top of Page

mark1504
Posting Yak Master

United Kingdom
103 Posts

Posted - 09/26/2006 :  15:53:13  Show Profile  Visit mark1504's Homepage  Send mark1504 a Yahoo! Message  Reply with Quote
Thanks for the prompt replies.

If it was my side, I'd be delighted as the solution would be in my hands. :-)

I've just now downloaded AquaFold and that connects with Aus, but I'd have to spend $149 p.a. to replace something I don't need to replace.

There's not really much to QA logins is there? Server name, user and password? What else could it be? I guess we're now down to how that server gets on with my version of QA (8.00.194). They've been getting on just fine for the last 2 years, up until suddenly last week!

Regards
Mark
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
36949 Posts

Posted - 09/26/2006 :  16:11:20  Show Profile  Visit tkizer's Homepage  Reply with Quote
So did you try the alias thing on your end that was suggested by both of us?

Tara Kizer
Go to Top of Page

mark1504
Posting Yak Master

United Kingdom
103 Posts

Posted - 09/26/2006 :  16:27:33  Show Profile  Visit mark1504's Homepage  Send mark1504 a Yahoo! Message  Reply with Quote
Hi Tara

Yes, I tried the Alias thing in Client Network Utility. No joy. :-(

Regards
Mark
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
36949 Posts

Posted - 09/26/2006 :  16:34:15  Show Profile  Visit tkizer's Homepage  Reply with Quote
Could you tell us what you selected for each option in the utility?

Tara Kizer
Go to Top of Page

X002548
Not Just a Number

15586 Posts

Posted - 09/27/2006 :  10:23:26  Show Profile  Reply with Quote
Did you ask if they chnaged anything? What's the name of the provider?



Brett

8-)

Hint: Want your questions answered fast? Follow the direction in this link
http://weblogs.sqlteam.com/brettk/archive/2005/05/25/5276.aspx

Add yourself!
http://www.frappr.com/sqlteam
Go to Top of Page

mark1504
Posting Yak Master

United Kingdom
103 Posts

Posted - 09/27/2006 :  10:44:36  Show Profile  Visit mark1504's Homepage  Send mark1504 a Yahoo! Message  Reply with Quote
tkizer, they don't seem to use or recommend the client network utility. I tried any number of combinations similar to the ones I have working fine for other site. I can't get any to work.

x002548, I asked if they'd changed anything and he denied it. (I have DEFINITELY not changed anything at this end.) By name of the provider, do you mean the company? www.xxxx.com

Edited by - mark1504 on 09/28/2006 02:47:56
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
36949 Posts

Posted - 09/27/2006 :  10:48:36  Show Profile  Visit tkizer's Homepage  Reply with Quote
The host doesn't need to use Client Network Utility. You do. It's for the clients only.

Tara Kizer
Go to Top of Page

X002548
Not Just a Number

15586 Posts

Posted - 09/27/2006 :  10:57:50  Show Profile  Reply with Quote
Have you tried their knowledge base or support?

https://support.quadrahosting.com/kb-article-7-0,4.html

Hey did you ask them if the service was running?

Oh that's right, you said the application is still up...Are you using Australia as a failover or is it just for a standalone app.

If it's web based, can we go there?



Brett

8-)

Hint: Want your questions answered fast? Follow the direction in this link
http://weblogs.sqlteam.com/brettk/archive/2005/05/25/5276.aspx

Add yourself!
http://www.frappr.com/sqlteam
Go to Top of Page

mark1504
Posting Yak Master

United Kingdom
103 Posts

Posted - 09/27/2006 :  11:13:38  Show Profile  Visit mark1504's Homepage  Send mark1504 a Yahoo! Message  Reply with Quote
In the client Network Utility the server name field does not permit commas. :-(

BTW, It's a live application, and the customer isn't affected by this situation at present.

I'm happy for someone else to try if you'd be so kind. Should I email the details rather than writing them here. Who wants a go? (Also I'm on Skype: therota)

Edited by - mark1504 on 09/27/2006 11:14:53
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
36949 Posts

Posted - 09/27/2006 :  11:16:32  Show Profile  Visit tkizer's Homepage  Reply with Quote
Why would you need commas for the server name?

Tara Kizer
Go to Top of Page

mark1504
Posting Yak Master

United Kingdom
103 Posts

Posted - 09/27/2006 :  11:18:18  Show Profile  Visit mark1504's Homepage  Send mark1504 a Yahoo! Message  Reply with Quote
It says enter mssql1.xxx,nnnn although I've tried it without.

Edited by - mark1504 on 09/28/2006 12:54:34
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
36949 Posts

Posted - 09/27/2006 :  11:21:53  Show Profile  Visit tkizer's Homepage  Reply with Quote
PortNumberGoesHere is the port number that SQL Server is listening on. Put that in the port section of the alias and not in the server name. If it is done right, you should end up with a registry value located here:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\Client\ConnectTo

The name of it would be mssql1.quadrahosting.com.au and the data value of it would be DBMSSOCN,mssql1.quadrahosting.com.au,PortNumberGoesHere.

Tara Kizer

Edited by - tkizer on 09/28/2006 12:47:16
Go to Top of Page

mark1504
Posting Yak Master

United Kingdom
103 Posts

Posted - 09/27/2006 :  11:40:32  Show Profile  Visit mark1504's Homepage  Send mark1504 a Yahoo! Message  Reply with Quote
Ok, so the TCP/IP is set up as nnnn
I go to alias and the following boxes
server alias - this contains the database name
server name - \\mssql1.?????.com
port number (greyed out) nnnn

Tara, the registry entry is as you described.

Shrugs shoulders. What else is there? I have 3 other connections (to UK and USA) running just fine here.


Edited by - mark1504 on 09/28/2006 12:55:34
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
36949 Posts

Posted - 09/27/2006 :  11:48:26  Show Profile  Visit tkizer's Homepage  Reply with Quote
There shold be no backslashes in the servername field. And the server alias should not contain the database name. Server alias should contain whatever name you are going to use to connect to the database server. I use the server name as the alias. It needs to be whatever your connection string has for the servername.

So server alias should be: mssql1.quadrahosting.com.au
Server name should be: mssql1.quadrahosting.com.au
Port: PortNumberGoesHere
Network library: TCP/IP

Tara Kizer

Edited by - tkizer on 09/28/2006 12:44:54
Go to Top of Page

mark1504
Posting Yak Master

United Kingdom
103 Posts

Posted - 09/27/2006 :  12:45:39  Show Profile  Visit mark1504's Homepage  Send mark1504 a Yahoo! Message  Reply with Quote
Tara, thank you very much! And thank you too Brett.

With those settings I'm in. It doesn't account for what actually changed. i.e. up until now there was nothing set up in Client Network Utility and it had been working fine since February 2004.

I wonder whether there is a setting that requires a TCP/IP alias to be used, and that that was only recently switched on? (Shrugs. Anyway, it's fixed thanks to you guys and I'm very grateful.)

Edited by - mark1504 on 09/27/2006 12:49:20
Go to Top of Page

tkizer
Almighty SQL Goddess

USA
36949 Posts

Posted - 09/27/2006 :  15:14:05  Show Profile  Visit tkizer's Homepage  Reply with Quote
Something occurred on your client machine to cause it not to be able to get to the proper port without the alias. So the problem was not on your host side, but rather on your side. I always create an alias for the database servers that I need to connect to, that way I don't run into connection problems like this.

Tara Kizer
Go to Top of Page

Kristen
Test

United Kingdom
22403 Posts

Posted - 09/27/2006 :  23:57:50  Show Profile  Reply with Quote
Guys: Should that port number be in plain text here, or am I being paranoid?

Kristen
Go to Top of Page
Page: of 2 Previous Topic Topic Next Topic  
Next Page
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.11 seconds. Powered By: Snitz Forums 2000