SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Other Forums
 SQL Server 6.5 \ SQL Server 7.0
 SQLServeragent Fails to Automatically start
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Cryptotech2000
Starting Member

3 Posts

Posted - 03/06/2007 :  12:09:35  Show Profile  Reply with Quote
For the past couple of months we have been having a problem with sqlserveragent service starting automatically upon system restart.. Here is a little bit of info hopefully this is enough if not please let me know and i will get what is needed to fix this problem..

When the system is restarted the service fails to load however it can be loaded manually afterwords with no problems once so ever most all of the threads i have found have a problem with manual loading also if they have the automatic start problem so i have a feeling mine is a different ballgame..

Server version 7
Latest SP has been installed
BUILTIN\Administrators account does exist and is granted
Role System administrators
Permitted in DB Role public and db_owner

I believe that this may have all started with an upgrade of nt4 to sp6 from sp4 but i am not positive on this as the server had never really been restarted prior to that so it may be something completley different

Once again if more information is needed please ask i am really hoping to fix this problem asap as it is delaying bills from being sent out when the system happens to restart and we do not catch it..

thank you

Cryptotech2000
Starting Member

3 Posts

Posted - 03/06/2007 :  12:15:03  Show Profile  Reply with Quote
Forgot to add the EventViewer logs

1:20:49 AM SQLServerAgent could not be started (reason: Unable to connect to server; SQLServerAgent cannot start)

1:20:49 AM SQLServerAgent service successfully stopped.
Go to Top of Page

elwoos
Flowing Fount of Yak Knowledge

United Kingdom
2050 Posts

Posted - 03/07/2007 :  03:32:42  Show Profile  Reply with Quote
This isn't to do with permissions is it? What account is used to start the service when it's done automatically? Does that have the permissions it needs?

steve

-----------

Don't worry head. The computer will do all the thinking from now on.
Go to Top of Page

Cryptotech2000
Starting Member

3 Posts

Posted - 03/07/2007 :  10:32:12  Show Profile  Reply with Quote
Ya know im going to laugh at myself if thats it ill check on it and get back to ya
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.06 seconds. Powered By: Snitz Forums 2000