SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2005 Forums
 SQL Server Administration (2005)
 SQL Agent not starting at all
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

njvorhies
Starting Member

USA
4 Posts

Posted - 03/28/2007 :  12:34:35  Show Profile  Reply with Quote
I am unable to get SQL Agent service to run under the same domain name that my SQL Server service is running under. It will start and continue to run when Server and Agent are both ran under the Local Account. But once the services are switched over to the domain account, the Server starts, but the Agent fails. The domain user has administrative rights on the server, along with admin rights to the SQL instance.

Here is the event log.

Event Type: Error
Event Source: SQLSERVERAGENT
Event Category: Service Control
Event ID: 103
Date: 3/28/2007
User: N/A
Computer: SQL2
Description: SQLServerAgent could not be started (reason: SQLServerAgent must be able to connect to the SQL Server as SysAdmin, but '(Unknown)' is not a member of the SysAdmin role).

Any help would be greatly appreciated or links to threads with answers.

pareshmotiwala
Constraint Violating Yak Guru

USA
323 Posts

Posted - 03/28/2007 :  16:05:15  Show Profile  Visit pareshmotiwala's Homepage  Click to see pareshmotiwala's MSN Messenger address  Send pareshmotiwala a Yahoo! Message  Reply with Quote
did you try using sqlserver service under domain account and sqlserveragent under a different account.
I have had problems when your sql server runs out of licences. sometimes the Network folks who control domain accounts disable an account from being used in two different places at the same time.

Regards
Paresh Motiwala
Boston, USA
Go to Top of Page

njvorhies
Starting Member

USA
4 Posts

Posted - 03/29/2007 :  14:53:44  Show Profile  Reply with Quote
It still will not start when run under another user. It will also NOT run when run under Local System while the other is run under the domain account. The only way it will run is when both are run under Local System. I have also tried adding the domain user to all of the SQL user groups, thinking that if it worked, I would go through, delete the user from each group one at a time until I figured out which group it needed to be in (assuming that one other than the SQL Agent group was needed for this service to run).
Go to Top of Page

njvorhies
Starting Member

USA
4 Posts

Posted - 03/29/2007 :  15:25:22  Show Profile  Reply with Quote
I am also getting this error message in the SQL logs.

Date 3/29/2007 2:01:16 PM
Log SQL Agent (Current - 3/29/2007 2:01:00 PM)

Message
[298] SQLServer Error: 15281, SQL Server blocked access to procedure 'dbo.sp_sqlagent_get_startup_info' of component 'Agent XPs' because this component is turned off as part of the security configuration for this server. A system administrator can enable the use of 'Agent XPs' by using sp_configure. For more information about enabling 'Agent XPs', see "Surface Area Configuration" in SQL Server Books Online. [SQLSTATE 42000]


I am tried through the Surface Area Configuration to enable the Agent also and it errors out like it does when trying to start the service through the Services window.
Go to Top of Page

njvorhies
Starting Member

USA
4 Posts

Posted - 03/30/2007 :  11:40:03  Show Profile  Reply with Quote
problem solved. I didn't have the user set up in the local group policy to be able to "lock pages in memory" once that was set and the server rebooted, the service ran just fine.
Go to Top of Page

riggaP
Starting Member

1 Posts

Posted - 07/17/2008 :  01:56:00  Show Profile  Reply with Quote
OMG Thankyou!

Had exactly the same problem with 2 DMZ machines (i.e. no domain user could be used). Been beating my head against a wall (and google) for nearly 2 days!
Go to Top of Page

DarkPeace
Starting Member

1 Posts

Posted - 08/08/2008 :  17:31:39  Show Profile  Reply with Quote
You GUYS Rock.. for anyone else on win2k3 goto :
Administrative Tools -> Local Security Policy -> New window - >Local Policies -> User Rights Assignment - > Lock pages in memory Properties.

Add your AD user here.

Note : It doesn't work until a reboot (yes i tried).

Thanks a bunch.

Edited by - DarkPeace on 08/08/2008 17:34:50
Go to Top of Page

CanadaDBA
Aged Yak Warrior

Canada
583 Posts

Posted - 09/19/2009 :  07:46:12  Show Profile  Reply with Quote
Thanks DarkPeace for adding the detailed steps. Regards!

quote:
Originally posted by DarkPeace

You GUYS Rock.. for anyone else on win2k3 goto :
Administrative Tools -> Local Security Policy -> New window - >Local Policies -> User Rights Assignment - > Lock pages in memory Properties.

Add your AD user here.

Note : It doesn't work until a reboot (yes i tried).

Thanks a bunch.




Canada DBA
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.09 seconds. Powered By: Snitz Forums 2000