SQL Server Forums
Profile | Register | Active Topics | Members | Search | Forum FAQ
 
Register Now and get your question answered!
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 SQL Server 2000 Forums
 SQL Server Development (2000)
 SQL: Distributed Transaction
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

NoFxPT
Starting Member

2 Posts

Posted - 04/18/2007 :  12:17:19  Show Profile  Reply with Quote
Hi folks,

i got sql server 2000 sp4 and im trying with a linked server to insert the same data in a sql table and also in a as400 (db2) table
i think the linked server is fine because i can see the tables and also i can insert data in as400 tables but with a simple insert but i created a trigger to do the replication of data in sql and as400 and when i try to insert and invoke the trigger it gives me this error:

Server: Msg 7391, Level 16, State 1, Procedure INSERT_WMCS01F, Line 18
The operation could not be performed because the OLE DB provider 'MSDASQL' was unable to begin a distributed transaction.
[OLE/DB provider returned message: [IBM][iSeries Access ODBC Driver]Enlist with DTC phase failed. 2]
OLE DB error trace [OLE/DB Provider 'MSDASQL' ITransactionJoin::JoinTransaction returned 0x8004d00a].

I would appreciate if you could help me...

PD: I already have tried many solutions presented in other foruns.. Someone who have already worked with this can say to me if the MSDASQL provider supports distributed transactions?

I also used the db2oleb to the linked server and i can see the tables i want in the enterprise manager so i guess the connection is fine but if i query the linked server with a select * from for example i get this error:

Server: Msg 7399, Level 16, State 1, Line 1
OLE DB provider 'DB2OLEDB' reported an error. The provider did not give any information about the error.
OLE DB error trace [OLE/DB Provider 'DB2OLEDB' IUnknown::QueryInterface returned 0x80004005: The provider did not give any information about the error.].

Regards,
Joel

Edited by - NoFxPT on 04/18/2007 12:21:48

mfemenel
Professor Frink

USA
1421 Posts

Posted - 04/18/2007 :  16:13:16  Show Profile  Visit mfemenel's Homepage  Reply with Quote
try using select into to get the data into a temp table and then use that temp table to do your insert into your main table. I've not solved this issue myself but this has let me work around it and stop pulling my hair out. (just about too late for that anyway but that could be a whole difft forum)

Mike
"oh, that monkey is going to pay"
Go to Top of Page

NoFxPT
Starting Member

2 Posts

Posted - 04/19/2007 :  07:22:39  Show Profile  Reply with Quote
hmm...

check this: http://support.microsoft.com/kb/277894

Do you have idead where can i download SNA Server 4.0 Service Pack 4? The microsoft link is broken...
Go to Top of Page

SwePeso
Patron Saint of Lost Yaks

Sweden
30120 Posts

Posted - 04/19/2007 :  07:33:12  Show Profile  Visit SwePeso's Homepage  Reply with Quote
Asked here too
http://sqlforums.windowsitpro.com/web/forum/messageview.aspx?catid=74&threadid=85156&enterthread=y


Peter Larsson
Helsingborg, Sweden
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
SQL Server Forums © 2000-2009 SQLTeam Publishing, LLC Go To Top Of Page
This page was generated in 0.08 seconds. Powered By: Snitz Forums 2000