Please start any new threads on our new site at We've got lots of great SQL Server experts to answer whatever question you can come up with.

 All Forums
 SQL Server 2005 Forums
 SQL Server Administration (2005)
 Error: 18452, Severity: 14, State: 1

Author  Topic 

Starting Member

15 Posts

Posted - 2008-07-02 : 02:04:08
Hi All
I am getting this error in error log
Login failed for user ''. The user is not associated with a trusted SQL Server connection
Error: 18452, Severity: 14, State: 1
and this when run the executable comes with application
[Microsoft][ODBC SQL Server Driver][SQL Server][Login failed for user", The user is not associated with a trusted SQL Server connection

already checked mixed authentication m ode is in use.

any help will be appreciated...

Slow But Sure Yak Herding Master

3608 Posts

Posted - 2008-07-02 : 04:44:09
What application? All the message is telling you is that a connection string is not passing the username through, so is therefore failing.
Go to Top of Page

Posting Yak Master

133 Posts

Posted - 2008-07-02 : 09:01:24
Go thru this

Go to Top of Page

Constraint Violating Yak Guru

491 Posts

Posted - 2008-07-02 : 10:07:55
I have also found that this error is received when using Windows authentication in the following situations:
1) The client is having issues communicating with the domain controller.
2) Between trusted domains, both networks are having issues communicating back and forth.

If #1 I find a reboot usually addresses the issue (of the client). If this is keeps occuring I suggest you get your network support involved. If #2 I definitely suggest you get your network support involved to resolve the root cause of the issue.
Go to Top of Page

Starting Member

27 Posts

Posted - 2008-07-04 : 17:12:37
I have also had this issue. The clue that it is network related is in the fact that the username is null or ''. You may also see a "SSPI handshake failed" error in the logs.

A third possible cause is if your network is under a heavy load. When we upgraded our switches from 100Mb to 1GB the problem went away.

Richard Fryar
SQL Server Articles and Tips
Go to Top of Page

Posting Yak Master

100 Posts

Posted - 2008-07-04 : 17:18:17
Start-> RUN -> cliconfg
Include NAMED PIPES and TCP/IP into ENABLED Protocols [if not already there]
Goto ALIAS TAB - > click on add -> Just write the SERVERNAME in the SERVER ALIAS BOx.
Try now...
If using MANAGEMENT STUDIO.. do this:
In the connect to server window, click on OPTIONS button. and from network protocols choose..Named Pipes and connect...

Database Painter.. Leaving strokes, that amaze! and inreturn, put value to your Work. I am a Database [Architect / Administrator]
Go to Top of Page

- Advertisement -